summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-28 13:35:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-28 13:37:26 +0100
commit64f7994bfc3e10a272af065482961553299453bf (patch)
tree5e7dd422abf1142f4504ff6fe098139c1193f2b9 /sys-fs/diskdev_cmds
parentpackage.mask: Last rite multiple unfetchable packages (diff)
downloadgentoo-64f7994bfc3e10a272af065482961553299453bf.tar.gz
gentoo-64f7994bfc3e10a272af065482961553299453bf.tar.bz2
gentoo-64f7994bfc3e10a272af065482961553299453bf.zip
sys-fs/diskdev_cmds: bump up to EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-fs/diskdev_cmds')
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r1.ebuild46
-rw-r--r--sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch4
2 files changed, 48 insertions, 2 deletions
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r1.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r1.ebuild
new file mode 100644
index 000000000000..9a8a9f2239de
--- /dev/null
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV=${PV%_p*}
+
+DESCRIPTION="HFS and HFS+ utils ported from OSX, supplies mkfs and fsck"
+HOMEPAGE="http://opendarwin.org"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${MY_PV}.tar.gz
+ mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+ "${WORKDIR}"/diskdev_cmds-${PV}.patch
+ "${FILESDIR}"/diskdev_cmds-respect-cflags.patch
+)
+
+src_compile() {
+ emake -f Makefile.lnx AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dosbin fsck_hfs.tproj/fsck_hfs
+ dosbin newfs_hfs.tproj/newfs_hfs
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfs
+ dosym /sbin/newfs_hfs /sbin/mkfs.hfsplus
+ dosym /sbin/fsck_hfs /sbin/fsck.hfs
+ dosym /sbin/fsck_hfs /sbin/fsck.hfsplus
+ doman newfs_hfs.tproj/newfs_hfs.8
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfs.8
+ newman newfs_hfs.tproj/newfs_hfs.8 mkfs.hfsplus.8
+ doman fsck_hfs.tproj/fsck_hfs.8
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfs.8
+ newman fsck_hfs.tproj/fsck_hfs.8 fsck.hfsplus.8
+}
diff --git a/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
index 3f939f61163a..8acafce6c913 100644
--- a/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
+++ b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
@@ -1,5 +1,5 @@
---- Makefile.lnx.bak 2009-07-22 11:58:10.000000000 -0400
-+++ Makefile.lnx 2009-07-22 11:57:37.000000000 -0400
+--- a/Makefile.lnx.bak 2009-07-22 11:58:10.000000000 -0400
++++ b/Makefile.lnx 2009-07-22 11:57:37.000000000 -0400
@@ -1,5 +1,5 @@
CC := gcc
-CFLAGS := -g3 -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1