summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-16 17:28:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-16 17:28:42 +0300
commitce1b396462a1336a6d92709a79ec836afc9579fc (patch)
tree02cd59e0f3ab5459b5c4c0953b6c7335235f0d5e /sys-fs
parentapp-vim/nerdtree: (live) update EAPI 7 -> 8 (diff)
downloadgentoo-ce1b396462a1336a6d92709a79ec836afc9579fc.tar.gz
gentoo-ce1b396462a1336a6d92709a79ec836afc9579fc.tar.bz2
gentoo-ce1b396462a1336a6d92709a79ec836afc9579fc.zip
sys-fs/quotatool: add 1.6.5
Closes: https://bugs.gentoo.org/931077 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quotatool/Manifest1
-rw-r--r--sys-fs/quotatool/quotatool-1.6.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/quotatool/Manifest b/sys-fs/quotatool/Manifest
index 13baeb67200d..7b9e0785fca3 100644
--- a/sys-fs/quotatool/Manifest
+++ b/sys-fs/quotatool/Manifest
@@ -1,3 +1,4 @@
DIST quotatool-1.6.2.tar.gz 147691 BLAKE2B 22eb1f5012b0dd19d52a795a493e7a51e9bab0d6e71b10d632a4f61faf6b54db5b0b6096fdc38b0fdd2879ebc2a4cb44e7279e735e09436a9def5018814b3478 SHA512 882bdc43e49ef69b1b2899da01faf7853524f67585b716bba195ea89a250a90a7796a225b7d141b68bf45c7524d9fe506000998e6e7dc113b559f95e6ed21e2c
DIST quotatool-1.6.3.gh.tar.gz 105408 BLAKE2B aad673bab49071122c3ddb64a6f9e3006b2fa2b958e00be35decf13b4cf8fb0d6e2f06278287275a90ae04a31e48e492e2be9f7abbc8522e9c454b86aaaa5271 SHA512 d21f41bf4d45116241885b9ba249ad49cd55043773ca1b6663b0d7ad2ad531d7411bc812338973e82b50c402987bf3910edd455ab83a8fd66c2b369c22297693
DIST quotatool-1.6.4.gh.tar.gz 108459 BLAKE2B 78b547e70e94aebcd7355fb88c2d8ddbde539a9f6b8737d27947e88990808b59b8dad0f81eb4de5888a4d10127f9a87bf60dddd9fbeaf9c9acdd864b124434e3 SHA512 ba753085235909a6eb11332eb704cd8b1816f74e9552b77b1b34833432b95ff5f92881ea60c36be3dbe09e6b39446c575993cfe51263ea3b664852e3d023b70a
+DIST quotatool-1.6.5.gh.tar.gz 108551 BLAKE2B 709d239b3157fd3751305b68374e4fd3ff4196aba268a8e134ef0d7794e2e3b8c9cfc81f44573fded3fac26089aa654023850b34dfa7a7801cdb9a144f19d073 SHA512 b22278445b5c2c0c71277f95a7d79862e96da4b644679efdfd99f18bc74780e88ae732f8e1dba81d50a97f132e6111b0000e34c2e1d1b1a05735654967a56268
diff --git a/sys-fs/quotatool/quotatool-1.6.5.ebuild b/sys-fs/quotatool/quotatool-1.6.5.ebuild
new file mode 100644
index 000000000000..ed451075ad74
--- /dev/null
+++ b/sys-fs/quotatool/quotatool-1.6.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command-line utility for filesystem quotas"
+HOMEPAGE="https://quotatool.ekenberg.se/"
+#SRC_URI="https://quotatool.ekenberg.se/${P}.tar.gz"
+SRC_URI="https://github.com/ekenberg/quotatool/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="sys-fs/quota"
+
+src_prepare() {
+ default
+ sed -e 's/gcc/${CC}/' -i tools/depend.sh || die # bug 931077
+}
+
+src_configure() {
+ tc-export CC
+ default
+}