summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 21:01:25 -0400
committerSam James <sam@gentoo.org>2024-03-26 12:27:29 +0000
commitf5e2fcbee63b44a819e8526f757e59aa758ec4fe (patch)
treea12ba995c46686c121c86b4d0e32b534788486b1 /sys-fs
parentnet-misc/balance: add sourceforge upstream metadata (diff)
downloadgentoo-f5e2fcbee63b44a819e8526f757e59aa758ec4fe.tar.gz
gentoo-f5e2fcbee63b44a819e8526f757e59aa758ec4fe.tar.bz2
gentoo-f5e2fcbee63b44a819e8526f757e59aa758ec4fe.zip
sys-fs/diskdev_cmds: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/863893 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
index f3adae2ed197..827b33bc27b7 100644
--- a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_PV=${PV%_p*}
@@ -29,6 +29,15 @@ PATCHES=(
)
src_compile() {
+ # -Werror=strict-alising
+ # https://bugs.gentoo.org/863893
+ # Upstream is entirely dead (since 2006!) and apple's opensource dump isn't
+ # exactly where you go to report (0) bugs to an automated feed.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
emake -f Makefile.lnx AR="$(tc-getAR)" CC="$(tc-getCC)"
}