summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-12-17 20:24:15 -0500
committerMike Pagano <mpagano@gentoo.org>2023-12-17 20:24:32 -0500
commit81b2fbf5e36ac4fb3c2567d06539461511bce6a7 (patch)
tree225203e7f8eca0043cfa211f97f1dd48cff1a27d /sys-kernel/git-sources
parentsys-devel/kgcc64: add 13.2.1_p20231216 (diff)
downloadgentoo-81b2fbf5e36ac4fb3c2567d06539461511bce6a7.tar.gz
gentoo-81b2fbf5e36ac4fb3c2567d06539461511bce6a7.tar.bz2
gentoo-81b2fbf5e36ac4fb3c2567d06539461511bce6a7.zip
sys-kernel/git-sources: add 6.7_rc6
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.7_rc6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 1b643144ee4f..d6ff0a47b9e7 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-6.7-rc2.patch 72006720 BLAKE2B 3c6fa7423f67b81d45edb526205dd53bc23d9f
DIST patch-6.7-rc3.patch 72363721 BLAKE2B 1afb63acd48364195e876515e11b71b19b5415c80ccea7cfc199265ad16a9b639d0580bcff35170da38b37d3fd2996c25872c0091c1d4c755f936ebced9d5c08 SHA512 e21b1597864babee6cd0a641c1ffb36d7262650937c0c7ad234ce33ad22ca1ad1969cb9ec8652395e109904c0b66898dd36c19e761bef6cabaa80d57b552cf03
DIST patch-6.7-rc4.patch 72676847 BLAKE2B f81414a35d846b7cca8192d7c0b5df98555f1a7d83c386ce73c0d4a47774c93703e6de01e68e9df8f826b9fcf376924108d119c490efa155a76f3333fee187f5 SHA512 4f6ea1d3f15108ddf3a291079024debccded77d91819e30488a945f23c93955b06aa3647f93ff224e38a98f1b8736dcc05c3f769b1513d6e577783329545a032
DIST patch-6.7-rc5.patch 73084909 BLAKE2B 094526599ccb63a3b7658178468a6188e179110ac80e0b3cb890047351cdd23b8ac68f18d90ec6c86f01577ad70e00c177ce1a1d5ebd84f4897ae49229f2bec7 SHA512 02c37a6fea68a1fa280a613f9d8dc88655c43004e42bcb2580e8983ff95fb08c57630e0fec55714cb028a234e28616e40c3642a92785e0fa9b437c0dccd06c81
+DIST patch-6.7-rc6.patch 73376662 BLAKE2B 78e4d145caddb81c033fac6388496090fb8d4900f9fde6e95fc8a7cf8c39fcaf3a63f26cf387354b2177fc1b5710e8aa2f721a58bb42807c081f3a3602e89f0b SHA512 3cf301c327adaead8021607cc6e4b72e2f0985319bed6578b272e765cdb859c34754b572e69d322f7397063086e9f6a4333bce47f2e4c9ff73c1a48c17a1743b
diff --git a/sys-kernel/git-sources/git-sources-6.7_rc6.ebuild b/sys-kernel/git-sources/git-sources-6.7_rc6.ebuild
new file mode 100644
index 000000000000..46873aec3fec
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.7_rc6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.6"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}