summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-12-03 12:28:49 -0500
committerMike Pagano <mpagano@gentoo.org>2021-12-03 12:28:49 -0500
commit1fbd9433ba34967bf919bd213695be2609cf57af (patch)
tree679bba16f6be58385da7d61d6d43c847e6e1dd30 /sys-kernel/linux-docs
parentwww-servers/nginx-unit: remove unused patch (diff)
downloadgentoo-1fbd9433ba34967bf919bd213695be2609cf57af.tar.gz
gentoo-1fbd9433ba34967bf919bd213695be2609cf57af.tar.bz2
gentoo-1fbd9433ba34967bf919bd213695be2609cf57af.zip
sys-kernel/linux-docs: Version bumps, remove old
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-docs')
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.10.83.ebuild (renamed from sys-kernel/linux-docs/linux-docs-5.10.57.ebuild)4
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.15.6.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index 7ab10c20e5a2..d0903ce4d50e 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -1 +1,2 @@
DIST linux-5.10.tar.xz 116606704 BLAKE2B b923d7b66309224f42f35f8a5fa219421b0a9362d2adacdadd8d96251f61f7230878ea297a269a7f3b3c56830f0b177e068691e1d7f88501a05653b0a13274d1 SHA512 95bc137d0cf9148da6a9d1f1a878698dc27b40f68e22c597544010a6c591ce1b256f083489d3ff45ff77753289b535135590194d88ef9f007d0ddab3d74de70e
+DIST linux-5.15.tar.xz 121913744 BLAKE2B 3921274b23f7938abdf3ed9334534b4581e13d7484303d3a5280eddb038999aaa8b836666a487472d9c4a219af0f06b9fecccaf348fb5510ab8762f4ef4b7e83 SHA512 d25ad40b5bcd6a4c6042fd0fd84e196e7a58024734c3e9a484fd0d5d54a0c1d87db8a3c784eff55e43b6f021709dc685eb0efa18d2aec327e4f88a79f405705a
diff --git a/sys-kernel/linux-docs/linux-docs-5.10.57.ebuild b/sys-kernel/linux-docs/linux-docs-5.10.83.ebuild
index 5b4bc6708650..5ca092dc68cc 100644
--- a/sys-kernel/linux-docs/linux-docs-5.10.57.ebuild
+++ b/sys-kernel/linux-docs/linux-docs-5.10.83.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
-inherit python-any-r1 toolchain-funcs
+PYTHON_COMPAT=( python3_{9,10} )
+inherit linux-info python-any-r1 toolchain-funcs
MY_PV="$(ver_cut 1-2)"
MY_P=linux-${MY_PV}
diff --git a/sys-kernel/linux-docs/linux-docs-5.15.6.ebuild b/sys-kernel/linux-docs/linux-docs-5.15.6.ebuild
new file mode 100644
index 000000000000..5ca092dc68cc
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-5.15.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_PV="$(ver_cut 1-2)"
+MY_P=linux-${MY_PV}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="graphviz"
+
+DEPEND=""
+RDEPEND="graphviz? ( media-gfx/graphviz )"
+BDEPEND="${PYTHON_DEPS}
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ media-libs/fontconfig"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}