summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-06 21:58:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-06 22:00:46 +0100
commit9dbaee7488a852b823c4afa7b109b4a924787b4f (patch)
tree2525c28a97b3770fd98e325079b592b2a6b205eb /sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
parentapp-doc/kicad-doc: Switch to cmake.eclass (diff)
downloadgentoo-9dbaee7488a852b823c4afa7b109b4a924787b4f.tar.gz
gentoo-9dbaee7488a852b823c4afa7b109b4a924787b4f.tar.bz2
gentoo-9dbaee7488a852b823c4afa7b109b4a924787b4f.zip
sys-libs/compiler-rt: Fix Python branches more
Suggested by Arfrever. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
index bad82273c129..5049bf3761b8 100644
--- a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
@@ -38,6 +38,7 @@ S=${WORKDIR}/${MY_P}
CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
+ use test || return 0
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -50,7 +51,7 @@ pkg_pretend() {
pkg_setup() {
llvm_pkg_setup
- use test && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
test_compiler() {