summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-11-04 13:41:59 -0400
committerMike Gilbert <floppym@gentoo.org>2023-11-04 13:41:59 -0400
commitbd7fe586d642e047d14c193950f883e0b7b17a6a (patch)
tree7cd5cd85d529fdc85e53994194b9a3289b5c2d06 /sys-libs/db/db-6.0.35-r4.ebuild
parenttoolchain-funcs.eclass: tc-ld-force-bfd: unset LD before calling tc-getLD (diff)
downloadgentoo-bd7fe586d642e047d14c193950f883e0b7b17a6a.tar.gz
gentoo-bd7fe586d642e047d14c193950f883e0b7b17a6a.tar.bz2
gentoo-bd7fe586d642e047d14c193950f883e0b7b17a6a.zip
sys-libs/db: call tc-ld-force-bfd before multilib code
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-libs/db/db-6.0.35-r4.ebuild')
-rw-r--r--sys-libs/db/db-6.0.35-r4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/db/db-6.0.35-r4.ebuild b/sys-libs/db/db-6.0.35-r4.ebuild
index 20268a5c9996..0ee187c58cea 100644
--- a/sys-libs/db/db-6.0.35-r4.ebuild
+++ b/sys-libs/db/db-6.0.35-r4.ebuild
@@ -104,6 +104,12 @@ src_prepare() {
-i "${S_BASE}"/test/tcl/reputils.tcl || die
}
+src_configure() {
+ # Force bfd before calling multilib_toolchain_setup
+ tc-ld-force-bfd #470634 #729510
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
local myconf=(
--enable-compat185
@@ -121,8 +127,6 @@ multilib_src_configure() {
$(use_enable test)
)
- tc-ld-force-bfd #470634 #729510
-
# compilation with -O0 fails on amd64, see bug #171231
if [[ ${ABI} == amd64 ]]; then
local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}