summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2024-06-29 16:19:48 -0700
committerJason Zaman <perfinion@gentoo.org>2024-06-29 17:30:16 -0700
commitc6d238a15babdc97b71356bbb5d811d951feb5de (patch)
treeb531784db94b997c04dff23816b0b8362f2ce90f /sys-libs/libsemanage
parentsys-libs/libselinux: update EAPI 7 -> 8 (diff)
downloadgentoo-c6d238a15babdc97b71356bbb5d811d951feb5de.tar.gz
gentoo-c6d238a15babdc97b71356bbb5d811d951feb5de.tar.bz2
gentoo-c6d238a15babdc97b71356bbb5d811d951feb5de.zip
sys-libs/libsemanage: update EAPI 7 -> 8
Also drop message about policy store migration. The policy store moved in 2015, it's been long enough now to not need the message anymore. Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/libsemanage-9999.ebuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/sys-libs/libsemanage/libsemanage-9999.ebuild b/sys-libs/libsemanage/libsemanage-9999.ebuild
index 3393a1021748..89603aab06a7 100644
--- a/sys-libs/libsemanage/libsemanage-9999.ebuild
+++ b/sys-libs/libsemanage/libsemanage-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="8"
PYTHON_COMPAT=( python3_{10..12} )
inherit python-r1 toolchain-funcs multilib-minimal
@@ -115,16 +115,3 @@ multiib_src_install_all() {
python_setup
python_fix_shebang "${ED}"/usr/libexec/selinux/semanage_migrate_store
}
-
-pkg_postinst() {
- # Migrate the SELinux semanage configuration store if not done already
- local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' "${EROOT}"/etc/selinux/config 2>/dev/null)
- if [ -n "${selinuxtype}" ] && [ ! -d "${EROOT}"/var/lib/selinux/${selinuxtype}/active ] ; then
- ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
- ewarn "from /etc/selinux to /var/lib/selinux. The migration will be run now."
- ewarn "If there are any issues, it can be done manually by running:"
- ewarn "/usr/libexec/selinux/semanage_migrate_store"
- ewarn "For more information, please see"
- ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
- fi
-}