summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-18 06:22:40 +0000
committerSam James <sam@gentoo.org>2022-11-18 06:22:43 +0000
commit37375f05866147e2b03a5639d80fdac2ed7bd7e1 (patch)
tree2ded7068a2d8b849b46ed394b8af527803df7ec9 /sys-libs/libxcrypt
parentsys-libs/libxcrypt: add 4.4.32 (diff)
downloadgentoo-37375f05866147e2b03a5639d80fdac2ed7bd7e1.tar.gz
gentoo-37375f05866147e2b03a5639d80fdac2ed7bd7e1.tar.bz2
gentoo-37375f05866147e2b03a5639d80fdac2ed7bd7e1.zip
sys-libs/libxcrypt: drop 4.4.31
Another short-lived release, although 4.4.32 isn't fixing a mistake in .31. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libxcrypt')
-rw-r--r--sys-libs/libxcrypt/Manifest1
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.31.ebuild331
2 files changed, 0 insertions, 332 deletions
diff --git a/sys-libs/libxcrypt/Manifest b/sys-libs/libxcrypt/Manifest
index cdf84f5fae68..9870ae6432d7 100644
--- a/sys-libs/libxcrypt/Manifest
+++ b/sys-libs/libxcrypt/Manifest
@@ -1,3 +1,2 @@
DIST libxcrypt-4.4.28-autotools.tar.xz 618560 BLAKE2B c56d510201651e36cbd950b5a0a32273fdbce1f053109aa5867b2c6a57e2a896c34c981c1a2e732a8f34539b754ebe7f50d1b5bf59f9549a75ad6420921f3e1d SHA512 3c60fd32dea308152c4272522c29668c83e88bea47c98b9fe796ed70f5460ad2a9616ffbe789c03e417b28d3c792361b16031bda3d8bc5b6c06f0ebdc66c8217
-DIST libxcrypt-4.4.31-autotools.tar.xz 624388 BLAKE2B a8eabba80a383148e82c114310a58213b9f74dab96bf78c62115edd841b53bf7f735a26277327f59abab86e77a98a5a4990a8d14e82d6cf2dbe717c48a80a80b SHA512 31275558c5d340ef3f99fffab1ab086e355f2d88ca524283459cfba523b68abcabd61f2fe9246ec9822e121c9376c6fb004a9647aff16728bfcc49421ca365b4
DIST libxcrypt-4.4.32-autotools.tar.xz 624332 BLAKE2B fbbbfe8ac6b1e9f283621d2bf3b554ba6652c5cea94932666a5a920c74fad7b0bc265fccdacc694113ed1c273a16e064b7aba45da83499e974741039484e7064 SHA512 dab13a858ac796c51cdcf9efbb6f525397ea8c1daa9c0169893228a17c767e4442b4fb9b7a40db46da1fc4f1752c4c8dda97a7b2c644a58377a053deb16e3ed9
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.31.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.31.ebuild
deleted file mode 100644
index d0bd8a723065..000000000000
--- a/sys-libs/libxcrypt/libxcrypt-4.4.31.ebuild
+++ /dev/null
@@ -1,331 +0,0 @@
-# Copyright 2004-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} )
-# NEED_BOOTSTRAP is for developers to quickly generate a tarball
-# for publishing to the tree.
-NEED_BOOTSTRAP="no"
-inherit eapi8-dosym multibuild multilib python-any-r1 flag-o-matic toolchain-funcs multilib-minimal
-
-DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others"
-HOMEPAGE="https://github.com/besser82/libxcrypt"
-if [[ ${NEED_BOOTSTRAP} == "yes" ]] ; then
- inherit autotools
- SRC_URI="https://github.com/besser82/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-autotools.tar.xz"
-fi
-
-LICENSE="LGPL-2.1+ public-domain BSD BSD-2"
-SLOT="0/1"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="+compat split-usr static-libs +system test headers-only"
-REQUIRED_USE="split-usr? ( system )"
-RESTRICT="!test? ( test )"
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-is_cross() {
- local enabled_abis=( $(multilib_get_enabled_abis) )
- [[ "${#enabled_abis[@]}" -le 1 ]] && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-DEPEND="
- system? (
- elibc_glibc? (
- ${CATEGORY}/glibc[-crypt(+)]
- !${CATEGORY}/glibc[crypt(+)]
- )
- elibc_musl? (
- ${CATEGORY}/musl[-crypt(+)]
- !${CATEGORY}/musl[crypt(+)]
- )
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-lang/perl
- test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
-
-python_check_deps() {
- python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
-}
-
-pkg_pretend() {
- if has "distcc" ${FEATURES} ; then
- ewarn "Please verify all distcc nodes are using the same versions of GCC (>= 10) and Binutils!"
- ewarn "Older/mismatched versions of GCC may lead to a misbehaving library: bug #823179."
-
- if [[ ${BUILD_TYPE} != "binary" ]] && tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]] ; then
- die "libxcrypt is known to fail to build or be broken at runtime with < GCC 10 (bug #823179)!"
- fi
- fi
-}
-
-pkg_setup() {
- MULTIBUILD_VARIANTS=(
- $(usex compat 'xcrypt_compat' '')
- xcrypt_nocompat
- )
-
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # WARNING: Please read on bumping or applying patches!
- #
- # There are two circular dependencies to be aware of:
- # 1)
- # if we're bootstrapping configure and makefiles:
- # libxcrypt -> automake -> perl -> libxcrypt
- #
- # mitigation:
- # toolchain@ manually runs `make dist` after running autoconf + `./configure`
- # and the ebuild uses that.
- # (Don't include the pre-generated Perl artefacts.)
- #
- # solution for future:
- # Upstream are working on producing `make dist` tarballs.
- # https://github.com/besser82/libxcrypt/issues/134#issuecomment-871833573
- #
- # 2)
- # configure *unconditionally* needs Perl at build time to generate
- # a list of enabled algorithms based on the set passed to `configure`:
- # libxcrypt -> perl -> libxcrypt
- #
- # mitigation:
- # None at the moment.
- #
- # solution for future:
- # Not possible right now. Upstream intend on depending on Perl for further
- # configuration options.
- # https://github.com/besser82/libxcrypt/issues/134#issuecomment-871833573
- #
- # Therefore, on changes (inc. bumps):
- # * You must check whether upstream have started providing tarballs with bootstrapped
- # auto{conf,make};
- #
- # * diff the build system changes!
- #
- if [[ ${NEED_BOOTSTRAP} == "yes" ]] ; then
- # Facilitate our split variant build for compat + non-compat
- eapply "${FILESDIR}"/${PN}-4.4.19-multibuild.patch
- eautoreconf
- fi
-}
-
-src_configure() {
- # Avoid possible "illegal instruction" errors with gold
- # bug #821496
- tc-ld-disable-gold
-
- # Doesn't work with LTO: bug #852917.
- # https://github.com/besser82/libxcrypt/issues/24
- filter-lto
-
- multibuild_foreach_variant multilib-minimal_src_configure
-}
-
-get_xcprefix() {
- if is_cross; then
- echo "${EPREFIX}/usr/${CTARGET}"
- else
- echo "${EPREFIX}"
- fi
-}
-
-get_xclibdir() {
- printf -- "%s/%s/%s/%s\n" \
- "$(get_xcprefix)" \
- "$(usex split-usr '' '/usr')" \
- "$(get_libdir)" \
- "$(usex system '' 'xcrypt')"
-}
-
-get_xcincludedir() {
- printf -- "%s/usr/include/%s\n" \
- "$(get_xcprefix)" \
- "$(usex system '' 'xcrypt')"
-}
-
-get_xcmandir() {
- printf -- "%s/usr/share/man\n" \
- "$(get_xcprefix)"
-}
-
-get_xcpkgconfigdir() {
- printf -- "%s/usr/%s/pkgconfig\n" \
- "$(get_xcprefix)" \
- "$(get_libdir)"
-}
-
-multilib_src_configure() {
- local -a myconf=(
- --host=${CTARGET}
- --disable-werror
- --libdir=$(get_xclibdir)
- --with-pkgconfigdir=$(get_xcpkgconfigdir)
- --includedir=$(get_xcincludedir)
- --mandir="$(get_xcmandir)"
- )
-
- tc-export PKG_CONFIG
-
- if is_cross; then
- if tc-is-clang; then
- export CC="${CTARGET}-clang"
- else
- export CC="${CTARGET}-gcc"
- fi
- fi
-
- case "${MULTIBUILD_ID}" in
- xcrypt_compat-*)
- myconf+=(
- --disable-static
- --disable-xcrypt-compat-files
- --enable-obsolete-api=yes
- )
- ;;
- xcrypt_nocompat-*)
- myconf+=(
- --enable-obsolete-api=no
- $(use_enable static-libs static)
- )
- ;;
- *) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
- esac
-
- if use headers-only; then
- # Nothing is compiled here which would affect the headers for the target.
- # So forcing CC is sane.
- headers_only_flags="CC=$(tc-getBUILD_CC)"
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}" "${headers_only_flags}"
-}
-
-src_compile() {
- use headers-only && return
-
- multibuild_foreach_variant multilib-minimal_src_compile
-}
-
-multilib_src_test() {
- emake check
-}
-
-src_test() {
- multibuild_foreach_variant multilib-minimal_src_test
-}
-
-src_install() {
- multibuild_foreach_variant multilib-minimal_src_install
-
- use headers-only || \
- (
- shopt -s failglob || die "failglob failed"
-
- # Make sure our man pages do not collide with glibc or man-pages.
- for manpage in "${D}$(get_xcmandir)"/man3/crypt{,_r}.?*; do
- mv -n "${manpage}" "$(dirname "${manpage}")/xcrypt_$(basename "${manpage}")" \
- || die "mv failed"
- done
- ) || die "failglob error"
-
- # Remove useless stuff from installation
- find "${ED}"/usr/share/doc/${PF} -type l -delete || die
- find "${ED}" -name '*.la' -delete || die
-
- # workaround broken upstream cross-* --docdir by installing files in proper locations
- if is_cross; then
- insinto "$(get_xcprefix)"/usr/share
- doins -r "${ED}"/usr/share/doc
- rm -r "${ED}"/usr/share/doc || die
- fi
-}
-
-multilib_src_install() {
- if use headers-only; then
- emake DESTDIR="${D}" install-nodist_includeHEADERS
- return
- fi
-
- emake DESTDIR="${D}" install
-
- # Don't install the libcrypt.so symlink for the "compat" version
- case "${MULTIBUILD_ID}" in
- xcrypt_compat-*)
- rm "${D}"$(get_xclibdir)/libcrypt$(get_libname) \
- || die "failed to remove extra compat libraries"
- ;;
- xcrypt_nocompat-*)
- if use split-usr; then
- (
- if use static-libs; then
- # .a files are installed to /$(get_libdir) by default
- # Move static libraries to /usr prefix or portage will abort
- shopt -s nullglob || die "failglob failed"
- static_libs=( "${D}"/$(get_xclibdir)/*.a )
-
- if [[ -n ${static_libs[*]} ]]; then
- dodir "/usr/$(get_xclibdir)"
- mv "${static_libs[@]}" "${ED}/usr/$(get_xclibdir)" \
- || die "Moving static libs failed"
- fi
- fi
-
- if use system; then
- # Move versionless .so symlinks from /$(get_libdir) to /usr/$(get_libdir)
- # to allow linker to correctly find shared libraries.
- shopt -s failglob || die "failglob failed"
-
- for lib_file in "${D}"$(get_xclibdir)/*$(get_libname); do
- lib_file_basename="$(basename "${lib_file}")"
- lib_file_target="$(basename "$(readlink -f "${lib_file}")")"
-
- # We already know we're in split-usr (checked above)
- # See bug #843209 (also worth keeping in mind bug #802222 too)
- local libdir_no_prefix=$(get_xclibdir)
- libdir_no_prefix=${libdir_no_prefix#${EPREFIX}}
- libdir_no_prefix=${libdir_no_prefix%/usr}
- dosym8 -r "/$(get_libdir)/${lib_file_target}" "/usr/${libdir_no_prefix}/${lib_file_basename}"
- done
-
- rm "${D}"$(get_xclibdir)/*$(get_libname) || die "Removing symlinks in incorrect location failed"
- fi
- )
- fi
- ;;
- *) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
- esac
-}
-
-pkg_preinst() {
- # Verify we're not in a bad case like bug #843209 with broken symlinks.
- # This can be dropped when, if ever, the split-usr && system && compat case
- # is cleaned up in *_src_install.
- local broken_symlinks=()
- mapfile -d '' broken_symlinks < <(
- find "${ED}" -type l ! -exec test -e {} \; -print0 2>/dev/null
- )
-
- [[ -z "${broken_symlinks[@]}" ]] && return
-
- eerror "Broken symlinks found before merging!"
- for symlink in "${broken_symlinks[@]}" ; do
- bad_dest="$(readlink -f ${symlink})"
- eerror "\t${symlink} is broken!"
- eerror "\treadlink -f ${symlink}:"
- eerror "\t\t${bad_dest}"
- die "Broken symlinks found! Aborting to avoid damaging system. Please report a bug."
- done
-}