summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 03:18:00 +0000
committerSam James <sam@gentoo.org>2022-11-19 03:19:14 +0000
commit08471e180567de161d0f3777c357a0ba2d9e9ac7 (patch)
tree41af0f2698359be7d574d1df08686637f9c06797 /sys-libs/minizip-ng
parentdev-cpp/elfio: add 3.11 (diff)
downloadgentoo-08471e180567de161d0f3777c357a0ba2d9e9ac7.tar.gz
gentoo-08471e180567de161d0f3777c357a0ba2d9e9ac7.tar.bz2
gentoo-08471e180567de161d0f3777c357a0ba2d9e9ac7.zip
sys-libs/minizip-ng: add 3.0.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/minizip-ng')
-rw-r--r--sys-libs/minizip-ng/Manifest1
-rw-r--r--sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch25
-rw-r--r--sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild93
3 files changed, 119 insertions, 0 deletions
diff --git a/sys-libs/minizip-ng/Manifest b/sys-libs/minizip-ng/Manifest
index a1c9881d8a0e..a2fc647f45d7 100644
--- a/sys-libs/minizip-ng/Manifest
+++ b/sys-libs/minizip-ng/Manifest
@@ -1 +1,2 @@
DIST minizip-ng-3.0.6.tar.gz 642138 BLAKE2B 3faddeef035da0417671ef5578b90ad9ec9a69f376d04fb8095f93e27e3276931ef432e179613e841e754ff6e915e8c631eeaa48795aaa87773e45465bd14afa SHA512 92aaad655e7dbec60ab8075435ccdc72314f75f0516aa4a16094215df2b14b108c2b49cdf6c876e396f0f43f52ad63f52ce7db2e119efe25c55b8b873bef9d4f
+DIST minizip-ng-3.0.7.tar.gz 643065 BLAKE2B e7026a5cc54fac6eba6fd1e79f8d53474966999aec1c24c70ff2207b93314f1e1cf5360841570ace66a30d6178f0057428757c7ba9b2d4bb14feb397142dedcb SHA512 01805ec955514efca32f4beb0e1241e94591d7d1d6119036c55d898a595de038bb18b8a2ffe5dab13101a890d14485aaefdf81680a7c60aa4ab3fd9de63ee991
diff --git a/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch b/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch
new file mode 100644
index 000000000000..57197d0da587
--- /dev/null
+++ b/sys-libs/minizip-ng/files/minizip-ng-3.0.7-system-gtest.patch
@@ -0,0 +1,25 @@
+https://github.com/zlib-ng/minizip-ng/pull/657
+
+From 3aa42e0520e4e7ffeae5a3def458c7ee0fefacb9 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 19 Nov 2022 03:09:34 +0000
+Subject: [PATCH] Search system for GTest before downloading. #654
+
+Distributions often do builds with no network access available
+for both security reasons and also to ensure reproducibility.
+
+This change tells CMake to query the system for a copy of gtest,
+but if it's not available, it'll fall back to downloading via
+FetchContent.
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -2,6 +2,8 @@ cmake_minimum_required(VERSION 3.12)
+
+ include(FetchContent)
+
++find_package(GTest)
++
+ enable_language(CXX)
+
+ if(NOT TARGET GTest::GTest)
+
diff --git a/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild b/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild
new file mode 100644
index 000000000000..12ebd223606a
--- /dev/null
+++ b/sys-libs/minizip-ng/minizip-ng-3.0.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake
+
+DESCRIPTION="Fork of the popular zip manipulation library found in the zlib distribution"
+HOMEPAGE="https://github.com/zlib-ng/minizip-ng"
+SRC_URI="https://github.com/zlib-ng/minizip-ng/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="compat openssl test zstd"
+RESTRICT="!test? ( test )"
+
+# Automagically prefers sys-libs/zlib-ng if installed, so let's
+# just depend on it as presumably it's better tested anyway.
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib-ng
+ virtual/libiconv
+ compat? ( !sys-libs/zlib[minizip] )
+ openssl? ( dev-libs/openssl:= )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-system-gtest.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMZ_COMPAT=$(usex compat)
+
+ -DMZ_BUILD_TESTS=$(usex test)
+ -DMZ_BUILD_UNIT_TESTS=$(usex test)
+
+ -DMZ_FETCH_LIBS=OFF
+ -DMZ_FORCE_FETCH_LIBS=OFF
+
+ # Compression library options
+ -DMZ_ZLIB=ON
+ -DMZ_BZIP2=ON
+ -DMZ_LZMA=ON
+ -DMZ_ZSTD=$(usex zstd)
+ -DMZ_LIBCOMP=OFF
+
+ # Encryption support options
+ -DMZ_PKCRYPT=ON
+ -DMZ_WZAES=ON
+ -DMZ_OPENSSL=$(usex openssl)
+ # TODO: Re-enable, ideally unconditionally, for arc4random
+ # Revisit when https://github.com/zlib-ng/minizip-ng/pull/648 fixed
+ -DMZ_LIBBSD=ON
+ -DMZ_SIGNING=ON
+
+ # Character conversion options
+ -DMZ_ICONV=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # TODO: investigate
+ -E "(raw-unzip-pkcrypt|raw-append-unzip-pkcrypt|raw-erase-unzip-pkcrypt|deflate-unzip-pkcrypt|deflate-append-unzip-pkcrypt|deflate-erase-unzip-pkcrypt|bzip2-unzip-pkcrypt|bzip2-append-unzip-pkcrypt|bzip2-erase-unzip-pkcrypt|lzma-unzip-pkcrypt|lzma-append-unzip-pkcrypt|lzma-erase-unzip-pkcrypt|xz-unzip-pkcrypt|xz-append-unzip-pkcrypt|xz-erase-unzip-pkcrypt|zstd-unzip-pkcrypt|zstd-append-unzip-pkcrypt|zstd-erase-unzip-pkcrypt)"
+ )
+
+ # TODO: A bunch of tests end up looping and writing over each other's files
+ # It gets better with a patch applied (see https://github.com/zlib-ng/minizip-ng/issues/623#issuecomment-1264518994)
+ # but still hangs.
+ cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+
+ if use compat ; then
+ ewarn "minizip-ng is experimental and replacing the system zlib[minizip] is dangerous"
+ ewarn "Please be careful!"
+ fi
+}