summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-28 04:49:27 +0100
committerSam James <sam@gentoo.org>2024-04-28 05:02:12 +0100
commitef4afbd75c2c6e8262d2de04930398dfbce1d1bc (patch)
treebb72b467df1dcc785de37eff5f02ccf07a4bd9b3 /sys-libs/ncurses
parentsys-libs/ncurses: add 6.5 (diff)
downloadgentoo-ef4afbd75c2c6e8262d2de04930398dfbce1d1bc.tar.gz
gentoo-ef4afbd75c2c6e8262d2de04930398dfbce1d1bc.tar.bz2
gentoo-ef4afbd75c2c6e8262d2de04930398dfbce1d1bc.zip
sys-libs/ncurses: tweaks to 6.5
* Cleanup PATCH_DATES as new release means starting anew * Cleanup whitespace left over from opaque settings * Pass --enable-fvisibility * Pass --disable-setuid-environ (bug #930806) * Add a TODO wrt gpm/PDEPEND/circular dep Closes: https://bugs.gentoo.org/930806 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ncurses-6.5-r1.ebuild (renamed from sys-libs/ncurses/ncurses-6.5.ebuild)85
1 files changed, 14 insertions, 71 deletions
diff --git a/sys-libs/ncurses/ncurses-6.5.ebuild b/sys-libs/ncurses/ncurses-6.5-r1.ebuild
index 3354bee12fbd..f4d21fed91c1 100644
--- a/sys-libs/ncurses/ncurses-6.5.ebuild
+++ b/sys-libs/ncurses/ncurses-6.5-r1.ebuild
@@ -43,74 +43,7 @@ if [[ ${PV} == *_p* ]] ; then
# This array should contain a list of all the snapshots since the last
# release if there's no megapatch available yet.
PATCH_DATES=(
- 20230107
- 20230114
- 20230121
- 20230128
- 20230211
- 20230218
- 20230225
- 20230311
- 20230401
- 20230408
- 20230415
- 20230418
- 20230423
- 20230424
- 20230429
- 20230506
- 20230514
- 20230520
- 20230527
- 20230603
- 20230610
- 20230615
- 20230617
- 20230624
- 20230625
- 20230701
- 20230708
- 20230715
- 20230722
- 20230729
- 20230805
- 20230812
- 20230819
- 20230826
- 20230902
- 20230909
- 20230917
- 20230918
- 20230923
- 20231001
- 20231007
- 20231014
- 20231016
- 20231021
- 20231028
- 20231104
- 20231111
- 20231118
- 20231121
- 20231125
- 20231202
- 20231209
- 20231217
- 20231223
- 20231230
- 20240106
- 20240113
- 20240120
- 20240127
- 20240203
- 20240210
- 20240217
- 20240224
- 20240302
- 20240309
- 20240323
- 20240330
- 20240413
+ #20240101
# Latest patch is just _pN = $(ver_cut 4)
$(ver_cut 4)
@@ -156,6 +89,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~
IUSE="ada +cxx debug doc gpm minimal profile split-usr +stack-realign static-libs test tinfo trace"
RESTRICT="!test? ( test )"
+# TODO: ncurses allows (and we take advantage of this, even) passing
+# the SONAME for dlopen() use, so only the header is needed at build time.
+# Maybe we should bundle a copy of gpm.h so we can move gpm to PDEPEND
+# which would be far nicer UX-wise.
DEPEND="gpm? ( sys-libs/gpm[${MULTILIB_USEDEP}] )"
# Block the older ncurses that installed all files w/SLOT=5, bug #557472
RDEPEND="
@@ -284,6 +221,7 @@ do_configure() {
# Now the rest of the various standard flags.
--with-shared
+ --enable-fvisibility
# (Originally disabled until bug #245417 is sorted out, but now
# just keeping it off for good, given nobody needed it until now
# (2022) and we're trying to phase out bdb.)
@@ -297,6 +235,13 @@ do_configure() {
# The configure script uses ldd to parse the linked output which
# is flaky for cross-compiling/multilib/ldd versions/etc...
$(use_with gpm gpm libgpm.so.1)
+
+ # bug #930806
+ --disable-setuid-environ
+ # TODO: Maybe do these for USE=hardened
+ #--disable-root-access
+ #--disable-root-environ
+
--disable-term-driver
--disable-termcap
--enable-symlinks
@@ -326,9 +271,7 @@ do_configure() {
if [[ ${target} == ncursest* ]] ; then
conf+=( --with-{pthread,reentrant} )
else
- conf+=(
- --without-{pthread,reentrant}
- )
+ conf+=( --without-{pthread,reentrant} )
fi
# Make sure each variant goes in a unique location.