summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-02-24 00:06:28 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-02-24 00:06:28 +0100
commit03979888c36ce4e953dcb4faf953522323a352bc (patch)
tree07d2fab008430ae83102308a0e1b4f3c9158a892 /sys-libs
parentwww-apps/element: drop 1.11.53, 1.11.55 (diff)
downloadgentoo-03979888c36ce4e953dcb4faf953522323a352bc.tar.gz
gentoo-03979888c36ce4e953dcb4faf953522323a352bc.tar.bz2
gentoo-03979888c36ce4e953dcb4faf953522323a352bc.zip
sys-libs/glibc: Add blocker for too old systemd (otherwise things in nspawns fail)
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.39-r1.ebuild5
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.39-r1.ebuild b/sys-libs/glibc/glibc-2.39-r1.ebuild
index 54ddcc4bbadb..cb9a3aab0ec1 100644
--- a/sys-libs/glibc/glibc-2.39-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r1.ebuild
@@ -36,6 +36,10 @@ MIN_KERN_VER="3.2.0"
# its seccomp filter!). Please double check this!
MIN_PAX_UTILS_VER="1.3.3"
+# Minimum systemd version needed (which contains any new syscall changes for
+# its seccomp filter!). Please double check this!
+MIN_SYSTEMD_VER="255"
+
if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
@@ -130,6 +134,7 @@ DEPEND="${COMMON_DEPEND}
"
RDEPEND="${COMMON_DEPEND}
!<app-misc/pax-utils-${MIN_PAX_UTILS_VER}
+ !<sys-apps/systemd-${MIN_SYSTEMD_VER}
perl? ( dev-lang/perl )
"
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d48d26dff251..2b8f64f7e6ad 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -36,6 +36,10 @@ MIN_KERN_VER="3.2.0"
# its seccomp filter!). Please double check this!
MIN_PAX_UTILS_VER="1.3.3"
+# Minimum systemd version needed (which contains any new syscall changes for
+# its seccomp filter!). Please double check this!
+MIN_SYSTEMD_VER="255"
+
if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
@@ -130,6 +134,7 @@ DEPEND="${COMMON_DEPEND}
"
RDEPEND="${COMMON_DEPEND}
!<app-misc/pax-utils-${MIN_PAX_UTILS_VER}
+ !<sys-apps/systemd-${MIN_SYSTEMD_VER}
perl? ( dev-lang/perl )
"