summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-07 03:01:16 +0000
committerSam James <sam@gentoo.org>2024-12-07 03:01:16 +0000
commit0a4168b743fe8dce53e5279191a4dd24c8d58422 (patch)
tree374b558acc979b3df10187485ab8b107ef58399c /sys-libs
parentnet-misc/curl: drop 8.7.1-r4 (diff)
downloadgentoo-0a4168b743fe8dce53e5279191a4dd24c8d58422.tar.gz
gentoo-0a4168b743fe8dce53e5279191a4dd24c8d58422.tar.bz2
gentoo-0a4168b743fe8dce53e5279191a4dd24c8d58422.zip
sys-libs/newlib: drop versions
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/Manifest2
-rw-r--r--sys-libs/newlib/newlib-4.1.0-r2.ebuild154
-rw-r--r--sys-libs/newlib/newlib-4.2.0.20211231-r1.ebuild154
-rw-r--r--sys-libs/newlib/newlib-4.3.0.20230120-r1.ebuild153
4 files changed, 0 insertions, 463 deletions
diff --git a/sys-libs/newlib/Manifest b/sys-libs/newlib/Manifest
index 5797ec3a58bd..9dd6901fa600 100644
--- a/sys-libs/newlib/Manifest
+++ b/sys-libs/newlib/Manifest
@@ -1,4 +1,2 @@
-DIST newlib-4.1.0.tar.gz 18648429 BLAKE2B c4d4d734bceeacf05b75d450d4316392d0000266812f98f99cd3f9f0926ac9848e1dc145361827d1d6951edfe5f109923c982d9f284f927ffc5fd5e5edaf8be6 SHA512 6a24b64bb8136e4cd9d21b8720a36f87a34397fd952520af66903e183455c5cf19bb0ee4607c12a05d139c6c59382263383cb62c461a839f969d23d3bc4b1d34
-DIST newlib-4.2.0.20211231.tar.gz 18921589 BLAKE2B fb85a368d082e2b9005d5d295d6854eb7d0e351cfade6516e6a06b18656d9139d7629f55a6d5f63337c6bce511a2373e797bed96847f19941b26cacfb1c8d3bc SHA512 0c3efd7b74a6b8457a717cbb6aa6c5ff268eeaba375535465c6bd6502c3d32b54a9bc3ba7f2c6990f78e29152eee2f62acb39b674d24f9ddf440374a1ec9d2e8
DIST newlib-4.3.0.20230120.tar.gz 8832922 BLAKE2B b5493f25e44049f4e1222698894e7e67756928062e05f5d16bcd52b2221e5c04a80a9e0cbc3fc6e92d67fe6b3813e06b6d3a6d39e8742e02b8f13ff84d809de1 SHA512 4a06309d36c2255fef8fc8f2d133cafa850f1ed2eddfb27b5d45f5d16af69e0fca829a0b4c9b34af4ed3a28c6fcc929761e0ee823a4229f35c2853d432b5e7ef
DIST newlib-4.4.0.20231231.tar.gz 9022406 BLAKE2B 1df810c7776aa1fe2806682509ab45df642f5e80d6069b7c6ca513b3d820440fc73abdf7505d1f3149d0a07f0c5558a48620d2824f1698c2f1df5f6473105eb4 SHA512 ea3baa0b7c9175aae024f0b7d272be092ef2c07483239a99329203e18a44bc23093d29e0ffcbe14bc591f610f0829eacd646cabb06d1c34aa23239cb1b814b46
diff --git a/sys-libs/newlib/newlib-4.1.0-r2.ebuild b/sys-libs/newlib/newlib-4.1.0-r2.ebuild
deleted file mode 100644
index 52f5c0cbde67..000000000000
--- a/sys-libs/newlib/newlib-4.1.0-r2.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.0-no-nano-cxx.patch
-)
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-# Adding -U_FORTIFY_SOURCE to counter the effect of Gentoo's
-# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
-# Currently newlib can't be built itself when _FORTIFY_SOURCE
-# is set.
-CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-
- case ${CTARGET} in
- msp430*)
- if ver_test $(gcc-version ${CTARGET}) -lt 10.1; then
- # bug #717610
- die "gcc for ${CTARGET} has to be 10.1 or above"
- fi
- ;;
- esac
-}
-
-src_configure() {
- # TODO: we should fix this
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
- CCASFLAGS_ORIG="${CCASFLAGS}"
- CFLAGS_ORIG="${CFLAGS}"
-
- local myconf=(
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-
- # Build newlib-nano beside newlib (original)
- # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
- if use nano ; then
- mkdir -p "${NEWLIBNANOBUILD}" || die
- cd "${NEWLIBNANOBUILD}" || die
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- --enable-newlib-reent-small \
- --disable-newlib-fvwrite-in-streamio \
- --disable-newlib-fseek-optimization \
- --disable-newlib-wide-orient \
- --enable-newlib-nano-malloc \
- --disable-newlib-unbuf-stream-opt \
- --enable-lite-exit \
- --enable-newlib-global-atexit \
- --enable-newlib-nano-formatted-io \
- "${myconf[@]}"
- fi
-}
-
-src_compile() {
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- emake -C "${NEWLIBBUILD}"
-
- if use nano ; then
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- emake -C "${NEWLIBNANOBUILD}"
- fi
-}
-
-src_install() {
- cd "${NEWLIBBUILD}" || die
- emake -j1 DESTDIR="${D}" install
-
- if use nano ; then
- cd "${NEWLIBNANOBUILD}" || die
- emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
- # Rename nano lib* files to lib*_nano and move to the real ${D}
- local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\)\.a" -print)
- for f in ${nanolibfiles}; do
- local l="${f##${NEWLIBNANOTMPINSTALL}}"
- mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
- done
-
- # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
- "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
- fi
-
- # minor hack to keep things clean
- rm -rf "${D}"/usr/share/info || die
- rm -rf "${D}"/usr/info || die
-}
diff --git a/sys-libs/newlib/newlib-4.2.0.20211231-r1.ebuild b/sys-libs/newlib/newlib-4.2.0.20211231-r1.ebuild
deleted file mode 100644
index 17fd43c36734..000000000000
--- a/sys-libs/newlib/newlib-4.2.0.20211231-r1.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.0-no-nano-cxx.patch
-)
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-# Adding -U_FORTIFY_SOURCE to counter the effect of Gentoo's
-# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
-# Currently newlib can't be built itself when _FORTIFY_SOURCE
-# is set.
-CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-
- case ${CTARGET} in
- msp430*)
- if ver_test $(gcc-version ${CTARGET}) -lt 10.1; then
- # bug #717610
- die "gcc for ${CTARGET} has to be 10.1 or above"
- fi
- ;;
- esac
-}
-
-src_configure() {
- # TODO: we should fix this
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
- CCASFLAGS_ORIG="${CCASFLAGS}"
- CFLAGS_ORIG="${CFLAGS}"
-
- local myconf=(
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-
- # Build newlib-nano beside newlib (original)
- # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
- if use nano ; then
- mkdir -p "${NEWLIBNANOBUILD}" || die
- cd "${NEWLIBNANOBUILD}" || die
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- --enable-newlib-reent-small \
- --disable-newlib-fvwrite-in-streamio \
- --disable-newlib-fseek-optimization \
- --disable-newlib-wide-orient \
- --enable-newlib-nano-malloc \
- --disable-newlib-unbuf-stream-opt \
- --enable-lite-exit \
- --enable-newlib-global-atexit \
- --enable-newlib-nano-formatted-io \
- "${myconf[@]}"
- fi
-}
-
-src_compile() {
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- emake -C "${NEWLIBBUILD}"
-
- if use nano ; then
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- emake -C "${NEWLIBNANOBUILD}"
- fi
-}
-
-src_install() {
- cd "${NEWLIBBUILD}" || die
- emake -j1 DESTDIR="${D}" install
-
- if use nano ; then
- cd "${NEWLIBNANOBUILD}" || die
- emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
- # Rename nano lib* files to lib*_nano and move to the real ${D}
- local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\|gloss\)\.a" -print)
- for f in ${nanolibfiles}; do
- local l="${f##${NEWLIBNANOTMPINSTALL}}"
- mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
- done
-
- # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${ED}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/${EPREFIX}/usr/${CTARGET}/include/newlib.h" \
- "${ED}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
- fi
-
- # minor hack to keep things clean
- rm -rf "${D}"/usr/share/info || die
- rm -rf "${D}"/usr/info || die
-}
diff --git a/sys-libs/newlib/newlib-4.3.0.20230120-r1.ebuild b/sys-libs/newlib/newlib-4.3.0.20230120-r1.ebuild
deleted file mode 100644
index 21ce7e99de7c..000000000000
--- a/sys-libs/newlib/newlib-4.3.0.20230120-r1.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.0-no-nano-cxx.patch
-)
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-CFLAGS_FULL="-ffunction-sections -fdata-sections"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-
- case ${CTARGET} in
- msp430*)
- if ver_test $(gcc-version ${CTARGET}) -lt 10.1; then
- # bug #717610
- die "gcc for ${CTARGET} has to be 10.1 or above"
- fi
- ;;
- esac
-}
-
-src_configure() {
- # TODO: we should fix this
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
- CCASFLAGS_ORIG="${CCASFLAGS}"
- CFLAGS_ORIG="${CFLAGS}"
-
- local myconf=(
- # The top-level configure doesn't utilize this flag, but subdirs do,
- # so autodetection for econf doesn't work. Add ourselves.
- --disable-silent-rules
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-
- # Build newlib-nano beside newlib (original)
- # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
- if use nano ; then
- mkdir -p "${NEWLIBNANOBUILD}" || die
- cd "${NEWLIBNANOBUILD}" || die
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- --enable-newlib-reent-small \
- --disable-newlib-fvwrite-in-streamio \
- --disable-newlib-fseek-optimization \
- --disable-newlib-wide-orient \
- --enable-newlib-nano-malloc \
- --disable-newlib-unbuf-stream-opt \
- --enable-lite-exit \
- --enable-newlib-global-atexit \
- --enable-newlib-nano-formatted-io \
- "${myconf[@]}"
- fi
-}
-
-src_compile() {
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- emake -C "${NEWLIBBUILD}"
-
- if use nano ; then
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- emake -C "${NEWLIBNANOBUILD}"
- fi
-}
-
-src_install() {
- cd "${NEWLIBBUILD}" || die
- emake DESTDIR="${D}" install
-
- if use nano ; then
- cd "${NEWLIBNANOBUILD}" || die
- emake DESTDIR="${NEWLIBNANOTMPINSTALL}" install
- # Rename nano lib* files to lib*_nano and move to the real ${D}
- local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\|gloss\)\.a" -print)
- for f in ${nanolibfiles}; do
- local l="${f##${NEWLIBNANOTMPINSTALL}}"
- mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
- done
-
- # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${ED}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/${EPREFIX}/usr/${CTARGET}/include/newlib.h" \
- "${ED}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
- fi
-
- # minor hack to keep things clean
- rm -rf "${D}"/usr/share/info || die
- rm -rf "${D}"/usr/info || die
-}