summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-16 02:35:56 +0100
committerSam James <sam@gentoo.org>2023-06-16 02:36:14 +0100
commitdc3acbe1cfc97a45f986c5ff46273f91dd75738a (patch)
tree83ef417b6dd4b24869c5c74a78e102d71687a346 /sys-libs
parentsys-libs/zlib-ng: tweak comment (diff)
downloadgentoo-dc3acbe1cfc97a45f986c5ff46273f91dd75738a.tar.gz
gentoo-dc3acbe1cfc97a45f986c5ff46273f91dd75738a.tar.bz2
gentoo-dc3acbe1cfc97a45f986c5ff46273f91dd75738a.zip
sys-libs/zlib-ng: add multilib
If this is ever going to be a thing with compat, we obviously need this. We could conditionalise stuff on USE=compat but I don't really see the value in that; still possible we could want this for newly built 32-bit stuff anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild (renamed from sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild)8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild
index 718d4ab949b5..f96bd980dbf9 100644
--- a/sys-libs/zlib-ng/zlib-ng-2.1.2.ebuild
+++ b/sys-libs/zlib-ng/zlib-ng-2.1.2-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Worth keeping an eye on 'develop' branch upstream for possible backports,
# as they copied this practice from sys-libs/zlib upstream.
-inherit cmake
+inherit cmake-multilib
DESCRIPTION="Fork of the zlib data compression library"
HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
@@ -31,7 +31,7 @@ PATCHES=(
"${FILESDIR}"/zlib-ng-2.1.2-cmake.patch
)
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DZLIB_COMPAT=$(usex compat)
-DZLIB_ENABLE_TESTS=$(usex test)
@@ -78,9 +78,7 @@ src_configure() {
cmake_src_configure
}
-src_install() {
- cmake_src_install
-
+pkg_postinst() {
if use compat ; then
ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
ewarn "Please be careful!"