summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Rostecki <vadorovsky@protonmail.com>2024-02-01 08:10:21 +0100
committerSam James <sam@gentoo.org>2024-02-21 07:07:49 +0000
commite2b4a39461adb558b3dbe8bdcadde871a07c0c64 (patch)
treec1ef9f7f488f3ebd5bebda304fbbf0e0c48c8f4c /sys-libs
parentdev-python/aiosqlite: Bump to 0.20.0 (diff)
downloadgentoo-e2b4a39461adb558b3dbe8bdcadde871a07c0c64.tar.gz
gentoo-e2b4a39461adb558b3dbe8bdcadde871a07c0c64.tar.bz2
gentoo-e2b4a39461adb558b3dbe8bdcadde871a07c0c64.zip
sys-libs/slang: Fix the build with LLD 17
LLD 17 rightfully complains about the undefined symbol being present in the version script, which is also not used anywhere. Closes: https://bugs.gentoo.org/915818 Signed-off-by: Michal Rostecki <vadorovsky@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/35129 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/slang/files/slang-2.3.3-remove-undefined-symbol-from-version-script.patch30
-rw-r--r--sys-libs/slang/slang-2.3.3.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-libs/slang/files/slang-2.3.3-remove-undefined-symbol-from-version-script.patch b/sys-libs/slang/files/slang-2.3.3-remove-undefined-symbol-from-version-script.patch
new file mode 100644
index 000000000000..d3085797d1f8
--- /dev/null
+++ b/sys-libs/slang/files/slang-2.3.3-remove-undefined-symbol-from-version-script.patch
@@ -0,0 +1,30 @@
+From f0d959a496cf47482904c62c91312aba5153f423 Mon Sep 17 00:00:00 2001
+From: Michal Rostecki <vadorovsky@gmail.com>
+Date: Thu, 1 Feb 2024 08:02:44 +0100
+Subject: [PATCH] Remove the undefined SLang_Rline_Quit symbol from the version
+ script
+
+This symbol is not defined and not used anywhere, it was present only
+in the version file, which triggered the following error when linking
+with LLD 17:
+
+ ld.lld: error: version script assignment of 'SLANG2' to symbol 'SLang_Rline_Quit' failed: symbol not defined
+---
+ src/slang.ver | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/slang.ver b/src/slang.ver
+index aa030c9..4b01f9f 100644
+--- a/src/slang.ver
++++ b/src/slang.ver
+@@ -70,7 +70,6 @@ SLANG2 {
+ SLang_Last_Key_Char;
+ SLang_Load_File_Hook;
+ SLang_Num_Function_Args;
+- SLang_Rline_Quit;
+ SLang_TT_Baud_Rate;
+ SLang_TT_Read_FD;
+ SLang_TT_Write_FD;
+--
+2.43.0
+
diff --git a/sys-libs/slang/slang-2.3.3.ebuild b/sys-libs/slang/slang-2.3.3.ebuild
index 2cf06ca437c9..1cf13c918011 100644
--- a/sys-libs/slang/slang-2.3.3.ebuild
+++ b/sys-libs/slang/slang-2.3.3.ebuild
@@ -37,6 +37,7 @@ MAKEOPTS+=" -j1"
PATCHES=(
"${FILESDIR}"/${PN}-2.3.3-slsh-libs.patch
+ "${FILESDIR}"/${PN}-2.3.3-remove-undefined-symbol-from-version-script.patch
)
src_prepare() {