summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-25 16:00:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-25 16:00:23 +0300
commit3e8b35d65cd6b019f0215ef98bd1a7a7e7833d3e (patch)
treef65176dec1785ac9c142048cbbbc45c231127337 /sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild
parentmedia-libs/imlib: drop 1.9.15-r7 (diff)
downloadgentoo-3e8b35d65cd6b019f0215ef98bd1a7a7e7833d3e.tar.gz
gentoo-3e8b35d65cd6b019f0215ef98bd1a7a7e7833d3e.tar.bz2
gentoo-3e8b35d65cd6b019f0215ef98bd1a7a7e7833d3e.zip
sys-process/pkill-darwin: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild')
-rw-r--r--sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild b/sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild
new file mode 100644
index 000000000000..6adbd78f04cb
--- /dev/null
+++ b/sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="pgrep(1) and pkill(1) for Darwin"
+HOMEPAGE="https://sourceforge.net/p/pkilldarwin/code/ci/default/tree/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm64-macos ~ppc-macos ~x64-macos"
+
+src_compile() {
+ edo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
+ # don't link, such that the suid trick described below won't make people
+ # suid their pkill too
+ cp pkill pgrep || die
+ ln -s pkill.1 pgrep.1 || die
+}
+
+src_install() {
+ into /usr
+ dobin pkill pgrep
+ doman pkill.1 pgrep.1
+}
+
+pkg_postinst() {
+ einfo "If you you want pgrep to be able to show and match on the arguments"
+ einfo "of all processes, you will have to make pgrep suid root. To do so"
+ einfo "you have to perform the following steps:"
+ einfo " % sudo chown root ${EPREFIX}/usr/bin/pgrep"
+ einfo " % sudo chmod u+s ${EPREFIX}/usr/bin/pgrep"
+}