summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandy Barlow <randy@electronsweatshop.com>2024-03-22 11:42:10 -0400
committerSam James <sam@gentoo.org>2024-04-04 02:05:36 +0100
commit3298173d86259e841ae72525e3a48ad586424a39 (patch)
tree0677ff41a6c3574a20b1c094334242d0d2613ee1 /virtual/rust
parentdev-lang/rust: Add 1.77.1 (diff)
downloadgentoo-3298173d86259e841ae72525e3a48ad586424a39.tar.gz
gentoo-3298173d86259e841ae72525e3a48ad586424a39.tar.bz2
gentoo-3298173d86259e841ae72525e3a48ad586424a39.zip
virtual/rust: Add 1.77.1
Signed-off-by: Randy Barlow <randy@electronsweatshop.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.77.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.77.1.ebuild b/virtual/rust/rust-1.77.1.ebuild
new file mode 100644
index 000000000000..187391b93274
--- /dev/null
+++ b/virtual/rust/rust-1.77.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt profiler"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler?,rustfmt?,${MULTILIB_USEDEP}]
+)"