summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-13 14:48:55 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-13 15:59:20 -0700
commitcbb0927d2bdead899288a2d90a4a9f584fb42bdd (patch)
treea3802a048310037afb9e17525b81d6f89d492702 /virtual/rust
parentdev-lang/rust: add 1.63.0 (diff)
downloadgentoo-cbb0927d2bdead899288a2d90a4a9f584fb42bdd.tar.gz
gentoo-cbb0927d2bdead899288a2d90a4a9f584fb42bdd.tar.bz2
gentoo-cbb0927d2bdead899288a2d90a4a9f584fb42bdd.zip
virtual/rust: add 1.63.0
Closes: https://bugs.gentoo.org/868330 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.63.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.63.0.ebuild b/virtual/rust/rust-1.63.0.ebuild
new file mode 100644
index 000000000000..b7da1d054aa3
--- /dev/null
+++ b/virtual/rust/rust-1.63.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"