summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_auth_tkt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_auth_tkt')
-rw-r--r--www-apache/mod_auth_tkt/Manifest1
-rw-r--r--www-apache/mod_auth_tkt/files/10_mod_auth_tkt.conf24
-rw-r--r--www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch40
-rw-r--r--www-apache/mod_auth_tkt/metadata.xml5
-rw-r--r--www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild53
5 files changed, 123 insertions, 0 deletions
diff --git a/www-apache/mod_auth_tkt/Manifest b/www-apache/mod_auth_tkt/Manifest
new file mode 100644
index 000000000000..24ff040b6e2e
--- /dev/null
+++ b/www-apache/mod_auth_tkt/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_tkt-2.1.0.tar.gz 100731 SHA256 ba456531656be5682f0a6a632a6eccb98c2459753c59b80b843e1d19cc7f8724 SHA512 e99ed60dbe2deebd654c4c849b20f7aa929ab476b9142e3da1aad8468b4922f4c36d30086396bb15676a3dc3e4ad9ac97e3524d1c70c6f18cea4c436174463b0 WHIRLPOOL f8fde3b318a1cd236e07baa23c39e6d5f6873c6097a54df438bc114383049c67b6db73789eab23fa8b8d8dee738424c8d832f9f286010d33a5e8b07565292f7c
diff --git a/www-apache/mod_auth_tkt/files/10_mod_auth_tkt.conf b/www-apache/mod_auth_tkt/files/10_mod_auth_tkt.conf
new file mode 100644
index 000000000000..4fe66cc90b5f
--- /dev/null
+++ b/www-apache/mod_auth_tkt/files/10_mod_auth_tkt.conf
@@ -0,0 +1,24 @@
+# See 'man mod_auth_tkt' for details on the individual directives.
+<IfDefine AUTH_TKT>
+LoadModule auth_tkt_module modules/mod_auth_tkt.so
+
+# Shared secret - CHANGE THIS before using!
+TKTAuthSecret "672c158d-67b8-42e4-aec7-f1e1abb882bb"
+
+# Used by sample CGI scripts to locate this config file
+SetEnv MOD_AUTH_TKT_CONF "/etc/apache2/modules.d/10_mod_auth_tkt.conf"
+
+# Protected directory example
+#<Directory /var/www/localhost/htdocs>
+# AuthType Basic
+# require valid-user
+# TKTAuthLoginURL https://www.CHANGEME.com/pub/login.cgi
+# # If an internet server, you probably want the following on (at least initially)
+# TKTAuthIgnoreIP on
+# # If you just want *optional* authentication, so that casual users and robots
+# # can still access some content, uncomment the following
+# # TKTAuthGuestLogin on
+#</Directory>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch b/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch
new file mode 100644
index 000000000000..af7cc2475169
--- /dev/null
+++ b/www-apache/mod_auth_tkt/files/mod_auth_tkt-2.1.0-apache-2.4.patch
@@ -0,0 +1,40 @@
+Description: Build fix for apache 2.4
+ Fix for API changes in apache 2.4.
+Author: Ivo De Decker <ivo.dedecker@ugent.be>
+Forwarded: http://sourceforge.net/mailarchive/forum.php?thread_name=20120518111425.GA9186%40ugent.be&forum_name=modauthtkt-users
+Last-Update: 2012-05-17
+
+--- libapache2-mod-auth-tkt-2.1.0.orig/src/mod_auth_tkt.c
++++ libapache2-mod-auth-tkt-2.1.0/src/mod_auth_tkt.c
+@@ -6,6 +6,7 @@
+ #include "http_config.h"
+ #include "http_log.h"
+ #include "http_core.h"
++#include "http_request.h"
+ #include "http_protocol.h"
+ #include "util_md5.h"
+ #include "sha2.h"
+@@ -798,7 +799,11 @@ ticket_digest(request_rec *r, auth_tkt *
+ unsigned char *buf2 = apr_palloc(r->pool, sconf->digest_sz + strlen(secret));
+ int len = 0;
+ char *digest = NULL;
++#if AP_MODULE_MAGIC_AT_LEAST(20111130,0)
++ char *remote_ip = conf->ignore_ip > 0 ? "0.0.0.0" : r->connection->client_ip;
++#else
+ char *remote_ip = conf->ignore_ip > 0 ? "0.0.0.0" : r->connection->remote_ip;
++#endif
+ unsigned long ip;
+ struct in_addr ia;
+ char *d;
+@@ -1575,7 +1580,11 @@ static void
+ auth_tkt_register_hooks (apr_pool_t *p)
+ {
+ ap_hook_post_config(auth_tkt_version, NULL, NULL, APR_HOOK_MIDDLE);
++#if AP_MODULE_MAGIC_AT_LEAST(20080403,1)
++ ap_hook_check_authn(auth_tkt_check, NULL, NULL, APR_HOOK_FIRST, AP_AUTH_INTERNAL_PER_CONF);
++#else
+ ap_hook_check_user_id(auth_tkt_check, NULL, NULL, APR_HOOK_FIRST);
++#endif
+ }
+
+ /* Declare and populate the main module data structure */
diff --git a/www-apache/mod_auth_tkt/metadata.xml b/www-apache/mod_auth_tkt/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_auth_tkt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..fdc4d21427e6
--- /dev/null
+++ b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module eutils
+
+DESCRIPTION="Apache module for cookie based authentication"
+HOMEPAGE="http://www.openfusion.com.au/labs/mod_auth_tkt/"
+SRC_URI="http://www.openfusion.com.au/labs/dist/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_TKT"
+
+DOCFILES="README"
+
+# test suite is completely broken
+RESTRICT="test"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-apache-2.4.patch
+}
+
+src_configure() {
+ ./configure --apachever=2.2 --apxs=${APXS}
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ apache-module_src_install
+ pod2man --section=5 --release=${PV} doc/${PN}.{pod,5}
+ doman doc/${PN}.5
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+ einfo "See 'man mod_auth_tkt' for details on the individual directives."
+ einfo "Remember to change shared secret 'TKTAuthSecret' before using!"
+ einfo
+}