summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-06-10 11:22:02 -0400
committerCraig Andrews <candrews@gentoo.org>2024-06-10 11:22:53 -0400
commit52c375f7b063b6c1798fce200f57d2ba61479733 (patch)
treea21911cf12afa7ebabaf01ebbac8f96a8f5646f7 /www-apache
parentwww-apache/mod_authnz_external: update EAPI 6 -> 7 (diff)
downloadgentoo-52c375f7b063b6c1798fce200f57d2ba61479733.tar.gz
gentoo-52c375f7b063b6c1798fce200f57d2ba61479733.tar.bz2
gentoo-52c375f7b063b6c1798fce200f57d2ba61479733.zip
www-apache/mod_authz_unixgroup: update EAPI 6 -> 7
Bug: https://bugs.gentoo.org/933847 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0-r1.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..4bc6217b5ac9
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README NOTICE"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}