summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/dokuwiki
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/Manifest2
-rw-r--r--www-apps/dokuwiki/dokuwiki-20140505e.ebuild68
-rw-r--r--www-apps/dokuwiki/dokuwiki-20140929d-r1.ebuild68
-rw-r--r--www-apps/dokuwiki/dokuwiki-20140929d.ebuild68
-rw-r--r--www-apps/dokuwiki/files/postinstall-en.txt52
-rw-r--r--www-apps/dokuwiki/metadata.xml17
6 files changed, 275 insertions, 0 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
new file mode 100644
index 000000000000..2a6111284e25
--- /dev/null
+++ b/www-apps/dokuwiki/Manifest
@@ -0,0 +1,2 @@
+DIST dokuwiki-2014-05-05e.tgz 3218289 SHA256 015b5e76427b97e584f195bab6652beaa80796f12f4a547ba9b6bc4e50387282 SHA512 b306be2378aed7119c9005fc9d0c8af4d89317eac19d633a992c6e37d9fb23e22493f25854e1803c892951ec995adf2a7689e04001666318614dd78813d0ffa4 WHIRLPOOL cb4823e7110fe83eea7d61fbf2937455b44a27805b849bc475ae5c9f74a4de353be283ebd8f2cf95a94df8ea395a2a34b9f2442e763a64c730401aee67347aa9
+DIST dokuwiki-2014-09-29d.tgz 3283317 SHA256 6fc6794e13c8e3fe07f5e02bd09cc3a167486a676e9822fa17aab0a45b094794 SHA512 426c41c5d7c6484cc6d5757dbe8e0ac50bf1088406c5c58d975f19fde5f6cb0a0dafb5a27c9901335b1d65a34578f46ffabbd44eed4f5bbd59d6c3fed1c769e3 WHIRLPOOL 59ea72ab973dfc5119056bfccbd5adae9a2ac45b13dbe5971325ca6e1bc4db2e8213aac1d5aab8d699b43b0602dd4b635841e7279e9535c63ed3d80cc85b1007
diff --git a/www-apps/dokuwiki/dokuwiki-20140505e.ebuild b/www-apps/dokuwiki/dokuwiki-20140505e.ebuild
new file mode 100644
index 000000000000..39a5745575aa
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20140505e.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.3[xml]
+ virtual/httpd-php:*
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/dokuwiki-20140929d-r1.ebuild b/www-apps/dokuwiki/dokuwiki-20140929d-r1.ebuild
new file mode 100644
index 000000000000..7a54790f3106
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20140929d-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.3[xml]
+ virtual/httpd-php:*
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/dokuwiki-20140929d.ebuild b/www-apps/dokuwiki/dokuwiki-20140929d.ebuild
new file mode 100644
index 000000000000..17559c8d503e
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20140929d.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.php
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-5.3[xml]
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/files/postinstall-en.txt b/www-apps/dokuwiki/files/postinstall-en.txt
new file mode 100644
index 000000000000..1816ba6bf88d
--- /dev/null
+++ b/www-apps/dokuwiki/files/postinstall-en.txt
@@ -0,0 +1,52 @@
+To complete installation you need to perform the following steps:
+
+ 1) Configure dokuwiki base options
+ 2) Check the config
+ 3) Notes
+
+1 - Configure dokuwiki base options
+
+ The first thing we need to do is set base options of dokuwiki:
+
+ $ cd ${MY_INSTALLDIR}/conf
+
+ Edit dokuwiki/conf/dokuwiki.php (see config [1]) if you want to change
+ anything within it. Better yet, create ${MY_INSTALLDIR}/conf/local.php containing
+ those lines from dokuwiki.php which you want to change. This way, your
+ changes are preserved when overwriting the dokuwiki.php with a new
+ release.
+
+ $ cp local.php.dist local.php
+
+2 - Check the config
+
+ Finally, test if everything is set up correctly. Use the check option in a
+ URL and pull it up into a browser:
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/doku.php?do=check
+
+3) - Notes
+
+ Please see the website [2] for more information on setting up dokuwiki.
+
+ Dokuwiki's default config leaves editing wide open, so please read the
+ acl [3] and user [4] documentation before proceding farther. If you use
+ the plaintext authentication, you may need to do the following:
+
+ $ cd conf/
+ $ cp users.auth.php.dist users.auth.php
+ $ cp acl.auth.php.dist acl.auth.php
+ $ chown apache:apache users.auth.php acl.auth.php
+
+ This enables apache to write to the files for editing the acl/user
+ creation capability.
+
+ If you're updating from an older version of Dokuwiki or want to learn about
+ other authentication methods, check the documentation about authentication
+ backends and plugins[5].
+
+[1] https://www.dokuwiki.org/config
+[2] https://www.dokuwiki.org/dokuwiki
+[3] https://www.dokuwiki.org/acl
+[4] https://www.dokuwiki.org/plugin:authplain
+[5] https://www.dokuwiki.org/auth
diff --git a/www-apps/dokuwiki/metadata.xml b/www-apps/dokuwiki/metadata.xml
new file mode 100644
index 000000000000..777b49b1aa79
--- /dev/null
+++ b/www-apps/dokuwiki/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>jmbsvicetto@gentoo.org</email>
+ <name>Jorge Manuel B. S. Vicetto</name>
+ </maintainer>
+ <longdescription lang="en">
+ DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at
+ creating documentation of any kind. It is targeted at developer teams,
+ workgroups and small companies. It has a simple but powerful syntax
+ which makes sure the datafiles remain readable outside the Wiki and
+ eases the creation of structured texts. All data is stored in plain text
+ files - no database is required.
+ </longdescription>
+</pkgmetadata>