summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-06-07 16:08:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-07 16:08:26 -0500
commit7041bf861b2afd5a15f1e9f8981d7c3403fbdb8d (patch)
treed897f90612555390b9c96168f5840e0d367b737d /www-apps/icingaweb2
parentdev-ruby/facter: 3.14.21 cleanup (diff)
downloadgentoo-7041bf861b2afd5a15f1e9f8981d7c3403fbdb8d.tar.gz
gentoo-7041bf861b2afd5a15f1e9f8981d7c3403fbdb8d.tar.bz2
gentoo-7041bf861b2afd5a15f1e9f8981d7c3403fbdb8d.zip
www-apps/icingaweb2: 2.10.0 cleanup
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.10.0.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 55e68f854999..6d21e3cb3463 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-2.10.0.tar.gz 11491028 BLAKE2B bee48e59ec7d0a564e7056986a84fda9639e61ed82ea65d35da310916e7058837fc146ee06f2c044748f72424198dc42f75b32de4b6ab39f673e2a9bbaf46966 SHA512 e26a4382970ece503c18ac9f93bb9e7ac24fd827dd84fd04352aeeff796ab58dac747840c6153cea5711d548603f219ba32aeffe76d87359ea72f2d3a598468b
DIST icingaweb2-2.10.1.tar.gz 11490414 BLAKE2B 897d5dcb4774db42651b53937f2bf80810b9a8d3eccb10bb733ce7b083e4eeea5673ee7cab75d24602871b72d44d84f7c1a6faec28c1ff4d2bd404a7d39d7ba2 SHA512 ba77ddeb27fb0ab1c6f7a77020eb9490803e1bf2d37186c7efc06bd250301a7d50f669699196d3a3208da9d5606edc787f62f34cdd15343e2c55020b77e485d8
diff --git a/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
deleted file mode 100644
index eb5a96a535d5..000000000000
--- a/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit depend.apache multilib
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
- dev-php/pecl-imagick
- pdf? ( media-gfx/imagemagick[png] )
- apache2-server? ( >=www-servers/apache-2.4.0 )
- nginx? ( >=www-servers/nginx-1.7.0:* )
- || (
- dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
- )
- dev-libs/icinga-php-library
- dev-libs/icinga-php-thirdparty
- acct-group/icingacmd
- acct-group/icingaweb2"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-
- use nginx && usermod -a -G icingacmd,icingaweb2 nginx
- use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
- if [[ -d /etc/icingaweb2 ]] ; then
- einfo "Updating existing installation ..."
- else
- einfo "Running first time setup ..."
- einfo "Creating configuration directory ..."
- /usr/share/${PN}/bin/icingacli setup config directory
- einfo "Creating authentication token for web setup ..."
- /usr/share/${PN}/bin/icingacli setup token create
- if use apache2 ; then
- einfo "The following might be useful for your Apache2 configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
- fi
- if use nginx ; then
- einfo "The following might be useful for your NGinx configuration:"
- /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
- fi
- fi
- einfo "All done."
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r "${S}"/*
- fperms -R a+rX "/usr/share/${PN}/public/"
- fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
- fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
- einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}