summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-07-11 09:50:57 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-07-11 14:28:03 +0200
commit85ed663c6b141f75077712e1f20de3fb10862f8c (patch)
tree840b48d1dcaf3ec48c396a55a8078d706f82cc5a /www-apps/nextcloud/nextcloud-14.0.13.ebuild
parentwww-apps/owncloud: drop old versions (diff)
downloadgentoo-85ed663c6b141f75077712e1f20de3fb10862f8c.tar.gz
gentoo-85ed663c6b141f75077712e1f20de3fb10862f8c.tar.bz2
gentoo-85ed663c6b141f75077712e1f20de3fb10862f8c.zip
www-apps/nextcloud: 16.0.3, 15.0.10, 14.0.13 bumps
Handle upcoming removal of dev-lang/php USE hash Closes: https://bugs.gentoo.org/688064 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud/nextcloud-14.0.13.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-14.0.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-14.0.13.ebuild b/www-apps/nextcloud/nextcloud-14.0.13.ebuild
new file mode 100644
index 000000000000..403ce74658a7
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-14.0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="http://nextcloud.com"
+SRC_URI="http://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+curl mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}