summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-10-14 10:42:56 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-11-15 01:05:45 -0500
commit49e2b2954269279e1f31d2f130698ae2a6349712 (patch)
tree87e0da08ea23d978afcaee66d896aec3818b47a2 /www-apps/radicale
parentdev-python/pipenv: unpin importlib-metadata dep (diff)
downloadgentoo-49e2b2954269279e1f31d2f130698ae2a6349712.tar.gz
gentoo-49e2b2954269279e1f31d2f130698ae2a6349712.tar.bz2
gentoo-49e2b2954269279e1f31d2f130698ae2a6349712.zip
www-apps/radicale: bump to 3.3.0
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'www-apps/radicale')
-rw-r--r--www-apps/radicale/Manifest1
-rw-r--r--www-apps/radicale/radicale-3.3.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 7c3dce0b5ba7..450086177b39 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -1,2 +1,3 @@
DIST Radicale-3.2.2.gh.tar.gz 155283 BLAKE2B e82e59bd90275cb6f5a32479a163032e12201144b250a7c7987619bc5343a4494952d263957aafc2ff1e2983b2edb339648f5aeb7bd84718b7ae0d1d20159d0f SHA512 12d1d40e6c63a5229948b9eed8d1311fcebc0b59506497966712810b8745475c3407f68cbafbf0a16b11985e1179aea4355ff2ab67ad9a8b7440443ea451cdcd
DIST Radicale-3.2.3.gh.tar.gz 157923 BLAKE2B 4beba122bc329cad27ebccd47655819e4769e58d4fe253bb8f064d4bef2cc2f9d9fd7c44b28a12a2f35e331ca1857bbf795d839ecfaf179983e8b1d54617b372 SHA512 992925ab82394fe5c94998ab23b8fa7d62ae3685ebc6f17497f67981758a9ea51757e48141dbedf20840610db8f3385a66d5a96cc24c3ba396ec67a522877be3
+DIST Radicale-3.3.0.gh.tar.gz 164215 BLAKE2B 5581e45b20d04d14d43cf4d133e6de001931beaa1100cff25c7726dac26ab03e008dd3cc5f85c69d6a8a6940d591a548d0e287aa5a9dd1194ea842ab94f8465f SHA512 02d4f1a6d2e298b74d7076d90a0bc2dc60e6d4b29b37279de3a15f4c1db7c9996685400c4899399a39693abd02b383c4862a59d6720292517543600c7b25fc06
diff --git a/www-apps/radicale/radicale-3.3.0.ebuild b/www-apps/radicale/radicale-3.3.0.ebuild
new file mode 100644
index 000000000000..9a7bd49246dc
--- /dev/null
+++ b/www-apps/radicale/radicale-3.3.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature systemd
+
+MY_P=${P^}
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="https://radicale.org/"
+SRC_URI="
+ https://github.com/Kozea/Radicale/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >=acct-user/radicale-0-r2
+ acct-group/radicale
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+RDIR=/var/lib/"${PN}"
+
+DOCS=( DOCUMENTATION.md CHANGELOG.md )
+
+python_test() {
+ epytest -o addopts= radicale/tests/
+}
+
+python_install_all() {
+ rm README* || die
+ # init file
+ newinitd "${FILESDIR}"/radicale-r4.init.d radicale
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # directories
+ keepdir "${RDIR}"
+ fperms 0750 "${RDIR}"
+ fowners "${PN}:${PN}" "${RDIR}"
+
+ # config file
+ insinto /etc/"${PN}"
+ doins config
+
+ # fcgi and wsgi files
+ exeinto /usr/share/"${PN}"
+ doexe radicale.wsgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ local _erdir="${EROOT}${RDIR}"
+
+ einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+ if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
+ then
+ ewarn ""
+ ewarn "Unsafe file permissions detected on ${_erdir}."
+ ewarn "This probably comes from an earlier version of this ebuild."
+ ewarn "To fix run:"
+ ewarn "# \`chown -R ${PN}:${PN} ${_erdir}\`"
+ ewarn "# \`chmod 0750 ${_erdir}\`"
+ ewarn "# \`chmod -R o= ${_erdir}\`"
+ fi
+
+ optfeature "Publish changes to rabbitmq" dev-python/pika
+ optfeature "LDAP/LDAPS authentication" dev-python/ldap3 dev-python/python-ldap
+}