summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-04-19 17:02:59 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-04-19 17:13:20 -0500
commitca573d1549829fdd82623f8e3fd5cf692db92e76 (patch)
tree460add24ea80d29611d470a894a0d60c7803cf2a /www-apps/trickster/trickster-0.1.9.ebuild
parentdev-db/sqlite: arm64 stable (bug #683858) (diff)
downloadgentoo-ca573d1549829fdd82623f8e3fd5cf692db92e76.tar.gz
gentoo-ca573d1549829fdd82623f8e3fd5cf692db92e76.tar.bz2
gentoo-ca573d1549829fdd82623f8e3fd5cf692db92e76.zip
www-apps/trickster: Dashboard Accelerator for Prometheus
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'www-apps/trickster/trickster-0.1.9.ebuild')
-rw-r--r--www-apps/trickster/trickster-0.1.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/trickster/trickster-0.1.9.ebuild b/www-apps/trickster/trickster-0.1.9.ebuild
new file mode 100644
index 000000000000..ef356ced058a
--- /dev/null
+++ b/www-apps/trickster/trickster-0.1.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user systemd
+
+DESCRIPTION="Dashboard Accelerator for Prometheus"
+HOMEPAGE="https://github.com/Comcast/trickster"
+VENDOR_URI="https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.gz"
+SRC_URI="https://github.com/Comcast/trickster/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${VENDOR_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go:="
+
+RESTRICT="strip"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ mv ../vendor .
+}
+
+src_compile() {
+ GOCACHE="${T}"/go-cache go build -a -mod vendor -v || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+dodoc -r conf docs/*
+ systemd_dounit conf/trickster.service
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ insinto /etc/trickster
+ doins "${FILESDIR}"/${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}