summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-05-12 22:57:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-05-12 22:57:09 +0100
commit15e998d86f5915ca56cb5b8c935b2a1786255d9e (patch)
treef8bf67e6157a5edd9dd830ae79257b7d82443c22 /www-apps/xpra-html5/xpra-html5-5.0.ebuild
parentvirtual/dist-kernel: Stabilize 5.15.37 arm64, #842897 (diff)
downloadgentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.tar.gz
gentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.tar.bz2
gentoo-15e998d86f5915ca56cb5b8c935b2a1786255d9e.zip
www-apps/xpra-html5: Version bump to 5.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps/xpra-html5/xpra-html5-5.0.ebuild')
-rw-r--r--www-apps/xpra-html5/xpra-html5-5.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/xpra-html5-5.0.ebuild b/www-apps/xpra-html5/xpra-html5-5.0.ebuild
new file mode 100644
index 000000000000..5c2270895f63
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ root="${D}",
+ install_dir="${EPREFIX}/usr/share/xpra/www/",
+ config_dir="${EPREFIX}/etc/xpra/html5-client",
+ minifier="$(usex minify uglifyjs copy)",
+ gzip=$(usex gzip True False),
+ brotli=$(usex brotli True False),
+)
+EOF
+}