summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-12-08 21:36:00 +0100
committerViorel Munteanu <ceamac@gentoo.org>2024-12-13 13:44:07 +0200
commit1b0d2ef862c1b22d8bb4679e5bf2fee9edbc1e85 (patch)
treebbb5fc44c370246d55f545bf8c288083a4290774 /www-apps
parentnet-im/mattermost-desktop-bin: add 5.10.2_rc2, drop 5.10.2_rc1 (diff)
downloadgentoo-1b0d2ef862c1b22d8bb4679e5bf2fee9edbc1e85.tar.gz
gentoo-1b0d2ef862c1b22d8bb4679e5bf2fee9edbc1e85.tar.bz2
gentoo-1b0d2ef862c1b22d8bb4679e5bf2fee9edbc1e85.zip
www-apps/rutorrent: add 5.1.3
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-5.1.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 26c13cdccbb8..21a248aa58f2 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.3.9.tar.gz 2378293 BLAKE2B 49f38626c69d70d502dcc8c1d9306920069a6072357d7152b8aa52e6de64ab0411948d0177bc973cdaebdfa7ffe6432c8d76683b6f427c5800bdc6b4aa496465 SHA512 5b4b35055a30c0295f693f9a94389e8df63ab234dd1f550a92b47efe2480b124fcac8a539c31ead910e3504feaace31e7bbdff76ddab77e1d268b00dc0a6cef2
DIST rutorrent-5.1.1.tar.gz 2694677 BLAKE2B 6cca0e9cd0078bc6024e55fc229ab3a392dd269b829be538bd045e861a12d66a77f7ba94fa17cdd4c7b47bb38a460e7961f1b7e1bb569c843cbdc0eb58b320b6 SHA512 59e93390ce189ff08af484add97b922cd002ef4622d0eed012da1263ffcc0850effec4fe4e05c95bcd9a2de24f314895b4b44b8473de629822f7b72195049856
+DIST rutorrent-5.1.3.tar.gz 2694675 BLAKE2B 0476db6f725c2bb9edd1b3b5f780dd4e693b823b6e21eb145d6a37c7929c56400a269d91a60ce8f1f7163338a90abbe6bc23c52dbad242ffa84fc9d7978433cc SHA512 08b2ad655dff9027cac22f975b89ab34cf66b1e833d68e76a87309cbb5671ba0d979fd53ff2e9cc93eaf49b9d53198e5d83336fca10b16120d8fc0834cbdeb24
diff --git a/www-apps/rutorrent/rutorrent-5.1.3.ebuild b/www-apps/rutorrent/rutorrent-5.1.3.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-5.1.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}