summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2023-11-05 10:03:36 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-01-11 16:05:46 +0200
commit48d09f299c2cd1e14b86c5385ffcd7ae64105429 (patch)
tree458900f5301fc9e89928d88845fcda9bbd760136 /www-apps
parentwww-apps/icingaweb2-module-director: add 1.11.0 (diff)
downloadgentoo-48d09f299c2cd1e14b86c5385ffcd7ae64105429.tar.gz
gentoo-48d09f299c2cd1e14b86c5385ffcd7ae64105429.tar.bz2
gentoo-48d09f299c2cd1e14b86c5385ffcd7ae64105429.zip
www-apps/icingaweb2-module-director: drop 1.10.2
Signed-off-by: Anton Fischl <github@fischl-online.de> Closes: https://github.com/gentoo/gentoo/pull/33675 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-director/Manifest1
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-1.10.2.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/www-apps/icingaweb2-module-director/Manifest b/www-apps/icingaweb2-module-director/Manifest
index 455f35328ab3..b063fce962f0 100644
--- a/www-apps/icingaweb2-module-director/Manifest
+++ b/www-apps/icingaweb2-module-director/Manifest
@@ -1,2 +1 @@
-DIST icingaweb2-module-director-1.10.2.tar.gz 3114956 BLAKE2B d050c501682ac3c1481d8710a3fc64642d0b18e92448bf05cd4a51e8a660c7a9abf571937a559a2dadd949535fca04feb1004a8613de7e4d0bbe54db5a377a25 SHA512 b301b71abada8c8722c03717a9def17c8ae53c951c83d5ef3a62f758fb93dd814d1b61d450987ddd0d8d3631145637dc6b26884134019e320cdd28cdedbc9794
DIST icingaweb2-module-director-1.11.0.tar.gz 3465395 BLAKE2B 8d0dcb590c3a735bcd279bf044c354b34f2f1edbc238a71236ec60e1e915660b80230c5076234cd6fb75fc7ec0ab1a8df967092c3f2f1c5e9305033b04236bf4 SHA512 1709920489248e7b6a84ffaa50996c9c061e04e744224fabc48a8885c30ed136cd0eb6db1a5e9a7bb3e07302b733554afa27060295b2ecea25f3416646656285
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.10.2.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.10.2.ebuild
deleted file mode 100644
index 370c6d78fa9b..000000000000
--- a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.10.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-DESCRIPTION="Icinga Web 2 plugin for configuration"
-HOMEPAGE="https://github.com/Icinga/icingaweb2-module-director/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/${PN}.git"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-# Dependencies according to https://github.com/Icinga/icingaweb2-module-director/blob/master/doc/02-Installation.md
-IUSE="php_targets_php8-1"
-
-PHP_DEPEND="
- php_targets_php8-1? ( dev-lang/php:8.1[curl,iconv,pcntl,posix,sockets] )
-"
-DEPEND="
- acct-group/icingaweb2
- acct-user/icingadirector
-"
-RDEPEND="
- ${PHP_DEPEND}
- ${DEPEND}
- >=www-apps/icingaweb2-module-incubator-0.18.0
- >=dev-libs/icinga-php-library-0.5.0
- >=dev-libs/icinga-php-thirdparty-0.9.0
- >=www-apps/icingaweb2-2.9.0
-"
-
-src_install() {
- insinto /usr/share/icingaweb2/modules/${PN##*-}/
- doins -r .
-
- exeinto /usr/share/icingaweb2/bin/
- doexe "${FILESDIR}"/icinga-director.sh
-
- doinitd "${FILESDIR}"/director
-
- keepdir /var/lib/${PN}
- fowners icingadirector:icingaweb2 /var/lib/${PN}
- fperms 0750 /var/lib/${PN}
- sed -e "s|/usr/bin/icingacli|/usr/share/icingaweb2/bin/icingacli|g" \
- contrib/systemd/icinga-director.service > "${T}"/icinga-director.service \
- || die "failed to patch icinga-director.service"
- systemd_dounit "${T}"/icinga-director.service
-}
-
-pkg_postinst() {
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if ver_test "${oldver}" -lt "1.10.0"; then
- ewarn "You are upgrading from ${oldver} to ${PVR}"
- ewarn "please read https://github.com/Icinga/icingaweb2-module-director/blob/master/doc/05-Upgrading.md#upgrade-to-1.10.x"
- ewarn "for breaking changes"
- ewarn
- ewarn "Also, don't forget to upgrade database schema."
- ewarn "Otherwise icingaweb2-module-director will not work!"
- ewarn "(Web GUI => Configuration => Modules => director => Configuration)"
- ewarn
- break
- fi
- done
-}