summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-07-17 20:19:36 -0400
committerCraig Andrews <candrews@gentoo.org>2023-07-17 20:20:52 -0400
commit4950d09a14c201c8fde28daa38733aa6afb8bcf4 (patch)
treec84271f8b682de63905102539ee15e722c987f80 /www-apps
parentnet-analyzer/net-snmp: port live to libpcre2 (diff)
downloadgentoo-4950d09a14c201c8fde28daa38733aa6afb8bcf4.tar.gz
gentoo-4950d09a14c201c8fde28daa38733aa6afb8bcf4.tar.bz2
gentoo-4950d09a14c201c8fde28daa38733aa6afb8bcf4.zip
www-apps/lidarr: fix logrotate configuration
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/lidarr/files/lidarr.logrotate2
-rw-r--r--www-apps/lidarr/lidarr-1.3.1.3371-r1.ebuild58
2 files changed, 59 insertions, 1 deletions
diff --git a/www-apps/lidarr/files/lidarr.logrotate b/www-apps/lidarr/files/lidarr.logrotate
index abd09ad04336..c1038e3cf9e8 100644
--- a/www-apps/lidarr/files/lidarr.logrotate
+++ b/www-apps/lidarr/files/lidarr.logrotate
@@ -1,4 +1,4 @@
-/var/lib/lidarr/.config/lidarr/logs/*.txt{
+/var/lib/lidarr/.config/Lidarr/logs/*.txt{
missingok
su lidarr lidarr
}
diff --git a/www-apps/lidarr/lidarr-1.3.1.3371-r1.ebuild b/www-apps/lidarr/lidarr-1.3.1.3371-r1.ebuild
new file mode 100644
index 000000000000..47d13184e338
--- /dev/null
+++ b/www-apps/lidarr/lidarr-1.3.1.3371-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="
+ amd64? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-x64.tar.gz )
+ arm? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-arm.tar.gz )
+ arm64? ( https://github.com/Lidarr/Lidarr/releases/download/v${PV}/Lidarr.develop.${PV}.linux-core-arm64.tar.gz )
+"
+
+DESCRIPTION="Looks and smells like Sonarr but made for music"
+HOMEPAGE="https://lidarr.audio"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/lidarr
+ acct-user/lidarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+ sys-libs/glibc
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Lidarr"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Lidarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/lidarr" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/lidarr.service"
+ systemd_newunit "${FILESDIR}/lidarr.service" "${PN}@.service"
+}