summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-23 09:37:12 +0100
committerSam James <sam@gentoo.org>2023-06-23 09:51:10 +0100
commita45f861fc09472e1fa29d8692eb6a918f4a1eee6 (patch)
treec6222c30c9c169a07d665ea3fa5cf3486691c60a /www-apps
parentwww-apps/jekyll-sass-converter: enable ruby31 (diff)
downloadgentoo-a45f861fc09472e1fa29d8692eb6a918f4a1eee6.tar.gz
gentoo-a45f861fc09472e1fa29d8692eb6a918f4a1eee6.tar.bz2
gentoo-a45f861fc09472e1fa29d8692eb6a918f4a1eee6.zip
www-apps/jekyll-coffeescript: enable ruby31
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jekyll-coffeescript/jekyll-coffeescript-2.0.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/www-apps/jekyll-coffeescript/jekyll-coffeescript-2.0.0.ebuild b/www-apps/jekyll-coffeescript/jekyll-coffeescript-2.0.0.ebuild
index efbc13877e54..fefe0ab957b2 100644
--- a/www-apps/jekyll-coffeescript/jekyll-coffeescript-2.0.0.ebuild
+++ b/www-apps/jekyll-coffeescript/jekyll-coffeescript-2.0.0.ebuild
@@ -2,25 +2,29 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby27 ruby30"
+
+USE_RUBY="ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
RUBY_FAKEGEM_TASK_DOC=""
-
RUBY_FAKEGEM_GEMSPEC="jekyll-coffeescript.gemspec"
inherit ruby-fakegem
-SRC_URI="https://github.com/jekyll/jekyll-coffeescript/archive/v${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A CoffeeScript Converter for Jekyll"
HOMEPAGE="https://github.com/jekyll/jekyll-coffeescript"
+SRC_URI="https://github.com/jekyll/jekyll-coffeescript/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="test"
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2
+ >=dev-ruby/coffee-script-source-1.12"
+ruby_add_bdepend "test? ( www-apps/jekyll )"
+
all_ruby_prepare() {
sed -i -e '/bundler/d' Rakefile || die
sed -i -e "/^RSpec/i \
@@ -29,7 +33,3 @@ all_ruby_prepare() {
require 'jekyll-coffeescript'" spec/spec_helper.rb || die
sed -i -e 's/git ls-files/find -type f -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
}
-
-ruby_add_rdepend ">=dev-ruby/coffee-script-2.2
- >=dev-ruby/coffee-script-source-1.12"
-ruby_add_bdepend "test? ( www-apps/jekyll )"