summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 20:45:34 +0100
committerSam James <sam@gentoo.org>2022-09-30 21:32:32 +0100
commit31f6cdae30ecc9fec095064bca94aa384ba65980 (patch)
tree6d57e5f31be54bbf76cd57b30848f7963e554451 /www-client/fetch
parentmuParser: wchar support (diff)
downloadgentoo-31f6cdae30ecc9fec095064bca94aa384ba65980.tar.gz
gentoo-31f6cdae30ecc9fec095064bca94aa384ba65980.tar.bz2
gentoo-31f6cdae30ecc9fec095064bca94aa384ba65980.zip
www-client/fetch: fix configure w/ clang 16
Old autoconf. Closes: https://bugs.gentoo.org/870499 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-client/fetch')
-rw-r--r--www-client/fetch/fetch-1.0-r4.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/www-client/fetch/fetch-1.0-r4.ebuild b/www-client/fetch/fetch-1.0-r4.ebuild
index 214f3e73c506..3e3ee5a9c8d0 100644
--- a/www-client/fetch/fetch-1.0-r4.ebuild
+++ b/www-client/fetch/fetch-1.0-r4.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="HTTP download tool built atop the HTTP fetcher library"
HOMEPAGE="https://sourceforge.net/projects/fetch/"
SRC_URI="mirror://sourceforge/fetch/${P}.tar.gz"
@@ -22,4 +24,7 @@ HTML_DOCS=( docs/fetch.html )
src_prepare() {
default
sed -i -e "/^ld_rpath/d" configure || die "sed failed"
+
+ # bug #870499
+ eautoreconf
}