summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-07 15:14:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-07 16:57:16 +0200
commit4a7cb9f5f6c19cbcf508adf6459bfef50cd3e06e (patch)
tree30eaf9c223a3f8347d3ceb7093d29bc9fc4744e0 /www-client/firefox
parentwww-client/firefox: drop old (diff)
downloadgentoo-4a7cb9f5f6c19cbcf508adf6459bfef50cd3e06e.tar.gz
gentoo-4a7cb9f5f6c19cbcf508adf6459bfef50cd3e06e.tar.bz2
gentoo-4a7cb9f5f6c19cbcf508adf6459bfef50cd3e06e.zip
www-client/firefox: add LLVM:12 support
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-78.10.1.ebuild10
-rw-r--r--www-client/firefox/firefox-88.0.1.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-78.10.1.ebuild b/www-client/firefox/firefox-78.10.1.ebuild
index 0668b5cf9276..c2e05bd89ee6 100644
--- a/www-client/firefox/firefox-78.10.1.ebuild
+++ b/www-client/firefox/firefox-78.10.1.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
FIREFOX_PATCHSET="firefox-78esr-patches-12.tar.xz"
-LLVM_MAX_SLOT=11
+LLVM_MAX_SLOT=12
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="ncurses,sqlite,ssl"
@@ -79,6 +79,14 @@ BDEPEND="${PYTHON_DEPS}
>=virtual/rust-1.41.0
|| (
(
+ sys-devel/clang:12
+ sys-devel/llvm:12
+ clang? (
+ =sys-devel/lld-12*
+ pgo? ( =sys-libs/compiler-rt-sanitizers-12*[profile] )
+ )
+ )
+ (
sys-devel/clang:11
sys-devel/llvm:11
clang? (
diff --git a/www-client/firefox/firefox-88.0.1.ebuild b/www-client/firefox/firefox-88.0.1.ebuild
index 85f03db61e8f..9f488363331d 100644
--- a/www-client/firefox/firefox-88.0.1.ebuild
+++ b/www-client/firefox/firefox-88.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
FIREFOX_PATCHSET="firefox-88-patches-03.tar.xz"
-LLVM_MAX_SLOT=11
+LLVM_MAX_SLOT=12
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="ncurses,sqlite,ssl"
@@ -78,6 +78,14 @@ BDEPEND="${PYTHON_DEPS}
>=virtual/rust-1.47.0
|| (
(
+ sys-devel/clang:12
+ sys-devel/llvm:12
+ clang? (
+ =sys-devel/lld-12*
+ pgo? ( =sys-libs/compiler-rt-sanitizers-12*[profile] )
+ )
+ )
+ (
sys-devel/clang:11
sys-devel/llvm:11
clang? (