summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-18 13:13:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-18 14:13:52 -0400
commitdc768c28cd19e1c773b9a96dee13d4b8ec3cd878 (patch)
tree47a98e2452f5bb416b4c6e8e15e79e7dcfad4506 /www-client/qutebrowser
parentdev-qt/qt-creator: update syntax-highlighting comment (diff)
downloadgentoo-dc768c28cd19e1c773b9a96dee13d4b8ec3cd878.tar.gz
gentoo-dc768c28cd19e1c773b9a96dee13d4b8ec3cd878.tar.bz2
gentoo-dc768c28cd19e1c773b9a96dee13d4b8ec3cd878.zip
www-client/qutebrowser: adjust tests skipping for Qt 6.7.2
version.py newly checks for chromium security version which fails given it does not know about 6.7.2's, and so just skip the whole suite given not very meaningful downstream. Also, Qt 6.7.2 introduced new warnings about failing to initialize vulkan and qutebrowser's tests fail if it sees unrecognized warnings. It might work if had mesa's lavapipe enabled in Xvfb but new warnings been a recurring issue and little sense in worrying further about these downstream. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild8
-rw-r--r--www-client/qutebrowser/qutebrowser-3.2.0.ebuild8
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild8
3 files changed, 15 insertions, 9 deletions
diff --git a/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild b/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild
index 3eb916073966..9fd58604459f 100644
--- a/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.1.0-r1.ebuild
@@ -111,9 +111,11 @@ src_prepare() {
fi
if use test; then
- # unnecessary here, and would require extra deps
+ # skip unnecessary (for us) pytest plugins, and ignore Qt's
+ # warnings that tend to newly appear with new versions
sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
-e '/pytest-instafail/d' -e 's/--instafail//' \
+ -e '/qt_log_level_fail/s/WARNING/CRITICAL/' \
-i pytest.ini || die
if [[ ${PV} == 9999 ]]; then
@@ -147,8 +149,8 @@ python_test() {
# needs _WRAPPER_OVERRIDE = None, but we have changed it
tests/unit/test_qt_machinery.py::TestSelectWrapper::test_autoselect_by_default
tests/unit/test_qt_machinery.py::TestInit::test_none_available_{implicit,explicit}
- # fails if chromium version is unrecognized (aka newer qtwebengine)
- tests/unit/utils/test_version.py::TestWebEngineVersions::test_real_chromium_version
+ # may fail if chromium version is unrecognized (aka newer qtwebengine)
+ tests/unit/utils/test_version.py
)
# tests known failing with Qt5 which is considered a 2nd class citizen
diff --git a/www-client/qutebrowser/qutebrowser-3.2.0.ebuild b/www-client/qutebrowser/qutebrowser-3.2.0.ebuild
index e0f7bb2a94cd..5525cd7811df 100644
--- a/www-client/qutebrowser/qutebrowser-3.2.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.2.0.ebuild
@@ -91,9 +91,11 @@ src_prepare() {
fi
if use test; then
- # unnecessary here, and would require extra deps
+ # skip unnecessary (for us) pytest plugins, and ignore Qt's
+ # warnings that tend to newly appear with new versions
sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
-e '/pytest-instafail/d' -e 's/--instafail//' \
+ -e '/qt_log_level_fail/s/WARNING/CRITICAL/' \
-i pytest.ini || die
if [[ ${PV} == 9999 ]]; then
@@ -124,8 +126,8 @@ python_test() {
tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
# may fail if environment is very large (bug #819393)
tests/unit/commands/test_userscripts.py::test_custom_env\[_POSIXUserscriptRunner\]
- # fails if chromium version is unrecognized (aka newer qtwebengine)
- tests/unit/utils/test_version.py::TestWebEngineVersions::test_real_chromium_version
+ # may fail if chromium version is unrecognized (aka newer qtwebengine)
+ tests/unit/utils/test_version.py
)
local epytestargs=(
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index e0f7bb2a94cd..5525cd7811df 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -91,9 +91,11 @@ src_prepare() {
fi
if use test; then
- # unnecessary here, and would require extra deps
+ # skip unnecessary (for us) pytest plugins, and ignore Qt's
+ # warnings that tend to newly appear with new versions
sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
-e '/pytest-instafail/d' -e 's/--instafail//' \
+ -e '/qt_log_level_fail/s/WARNING/CRITICAL/' \
-i pytest.ini || die
if [[ ${PV} == 9999 ]]; then
@@ -124,8 +126,8 @@ python_test() {
tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
# may fail if environment is very large (bug #819393)
tests/unit/commands/test_userscripts.py::test_custom_env\[_POSIXUserscriptRunner\]
- # fails if chromium version is unrecognized (aka newer qtwebengine)
- tests/unit/utils/test_version.py::TestWebEngineVersions::test_real_chromium_version
+ # may fail if chromium version is unrecognized (aka newer qtwebengine)
+ tests/unit/utils/test_version.py
)
local epytestargs=(