summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-04-15 11:35:11 +0000
committerYixun Lan <dlan@gentoo.org>2024-04-15 11:48:34 +0000
commit274780d56dd7bba824041db018427bea2b451365 (patch)
tree5e4717c4549be8ca09e973ebfb3d493ec2935db6 /www-client
parentprofiles/base: remove obsolete use.mask on ant-ivy, rhino and tomcat (diff)
downloadgentoo-274780d56dd7bba824041db018427bea2b451365.tar.gz
gentoo-274780d56dd7bba824041db018427bea2b451365.tar.bz2
gentoo-274780d56dd7bba824041db018427bea2b451365.zip
www-client/firefox: fix compilation errors on ARCH=riscv
- drop '--disable-elf-hack', as not available on RISC-V - fix flac decoder build failure, similar as bug #919418 Closes: https://bugs.gentoo.org/930046 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-124.0.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-124.0.2.ebuild b/www-client/firefox/firefox-124.0.2.ebuild
index 6f3569d8404b..83133451fc36 100644
--- a/www-client/firefox/firefox-124.0.2.ebuild
+++ b/www-client/firefox/firefox-124.0.2.ebuild
@@ -611,7 +611,7 @@ src_prepare() {
rm -v "${WORKDIR}"/firefox-patches/*-LTO-Only-enable-LTO-*.patch || die
fi
- if ! use ppc64; then
+ if ! use ppc64 && ! use riscv; then
rm -v "${WORKDIR}"/firefox-patches/*ppc64*.patch || die
fi
@@ -1061,8 +1061,9 @@ src_configure() {
else
mozconfig_add_options_ac 'relr elf-hack' --enable-elf-hack=relr
fi
- elif use ppc64 ; then
- # '--disable-elf-hack' is not recognized on ppc64, bgo#917049
+ elif use ppc64 || use riscv ; then
+ # '--disable-elf-hack' is not recognized on ppc64/riscv,
+ # see bgo #917049, #930046
:;
else
mozconfig_add_options_ac 'disable elf-hack on non-supported arches' --disable-elf-hack