summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-05 20:24:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-07 07:19:22 +0000
commit6329f9f3f20d3a8178404b7bf05397d34036ab30 (patch)
tree71151374cb43a78351a7901fcd2bf6aa04411ce5 /www-misc/urlwatch/files
parentdev-python/chump: new package, optional dependency for www-misc/urlwatch (diff)
downloadgentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.tar.gz
gentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.tar.bz2
gentoo-6329f9f3f20d3a8178404b7bf05397d34036ab30.zip
www-misc/urlwatch: bump to 2.2, use HTTPS URLs
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1830 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-misc/urlwatch/files')
-rw-r--r--www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch b/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
new file mode 100644
index 000000000000..66626dbf0259
--- /dev/null
+++ b/www-misc/urlwatch/files/urlwatch-2.2-fix-install.patch
@@ -0,0 +1,42 @@
+From ebe7b90100a3d960f53fdc9409d2d89eaa61bf11 Mon Sep 17 00:00:00 2001
+From: Thomas Perl <m@thp.io>
+Date: Tue, 28 Jun 2016 18:15:51 +0200
+Subject: [PATCH] Check current directory and use os.path.relpath (Fixes #73)
+
+---
+ setup.py | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 947a7c8..45405cd 100644
+--- a/setup.py
++++ b/setup.py
+@@ -7,10 +7,15 @@
+
+ import os
+ import re
++import sys
+
+ PACKAGE_NAME = 'urlwatch'
+ DEPENDENCIES = ['minidb', 'PyYAML', 'requests']
+-HERE = os.path.dirname(__file__)
++HERE = os.path.abspath(os.path.dirname(__file__))
++
++if os.path.normpath(os.getcwd()) != os.path.normpath(HERE):
++ print('You must run {} inside {} (cwd={})'.format(os.path.basename(__file__), HERE, os.getcwd()))
++ sys.exit(1)
+
+ # Assumptions:
+ # 1. Package name equals main script file name (and only one script)
+@@ -29,9 +34,9 @@
+
+ m['scripts'] = [os.path.join(HERE, PACKAGE_NAME)]
+ m['package_dir'] = {'': os.path.join(HERE, 'lib')}
+-m['packages'] = ['.'.join(dirname[len(HERE)+1:].split(os.sep)[1:])
++m['packages'] = ['.'.join(os.path.relpath(dirname, HERE).split(os.sep)[1:])
+ for dirname, _, files in os.walk(os.path.join(HERE, 'lib')) if '__init__.py' in files]
+-m['data_files'] = [(dirname[len(HERE)+1:], [os.path.join(dirname[len(HERE)+1:], fn) for fn in files])
++m['data_files'] = [(os.path.relpath(dirname, HERE), [os.path.join(os.path.relpath(dirname, HERE), fn) for fn in files])
+ for dirname, _, files in os.walk(os.path.join(HERE, 'share')) if files]
+ m['install_requires'] = DEPENDENCIES
+