summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-26 21:32:28 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-26 21:33:32 -0800
commitbc55bc20b65839ca8f8d56eceb13e98325ac4459 (patch)
treec0bfb928d06eef4e6e4e36bff8b913dd435bd448 /www-plugins/browserpass/browserpass-3.0.9.ebuild
parentapp-text/opensp: drop IUSE="elibc_glibc" (diff)
downloadgentoo-bc55bc20b65839ca8f8d56eceb13e98325ac4459.tar.gz
gentoo-bc55bc20b65839ca8f8d56eceb13e98325ac4459.tar.bz2
gentoo-bc55bc20b65839ca8f8d56eceb13e98325ac4459.zip
www-plugins/browserpass: Version bump to 3.0.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-plugins/browserpass/browserpass-3.0.9.ebuild')
-rw-r--r--www-plugins/browserpass/browserpass-3.0.9.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/www-plugins/browserpass/browserpass-3.0.9.ebuild b/www-plugins/browserpass/browserpass-3.0.9.ebuild
new file mode 100644
index 000000000000..a0cb85e673a8
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-3.0.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+MY_PN=browserpass-native
+
+DESCRIPTION="WebExtension host binary for app-admin/pass, a UNIX password manager"
+HOMEPAGE="https://github.com/browserpass/browserpass-native"
+
+EGO_SUM=(
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.1"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/mattn/go-zglob v0.0.3"
+ "github.com/mattn/go-zglob v0.0.3/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/rifflock/lfshook v0.0.0-20180920164130-b9218ef580f5"
+ "github.com/rifflock/lfshook v0.0.0-20180920164130-b9218ef580f5/go.mod"
+ "github.com/sirupsen/logrus v1.8.1"
+ "github.com/sirupsen/logrus v1.8.1/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/testify v1.2.2"
+ "github.com/stretchr/testify v1.2.2/go.mod"
+ "github.com/stretchr/testify v1.3.0"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037"
+ "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037/go.mod"
+ "golang.org/x/sys v0.0.0-20220207234003-57398862261d"
+ "golang.org/x/sys v0.0.0-20220207234003-57398862261d/go.mod"
+ )
+go-module_set_globals
+SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="BSD ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="app-crypt/gnupg"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_compile() {
+ go build || die
+
+ sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass-native|' \
+ -i browser-files/firefox-host.json browser-files/chromium-host.json || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe browserpass-native
+
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /usr/lib64/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+
+ insinto /etc/opt/chrome/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+}