summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-27 19:06:08 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-27 19:06:08 -0400
commit1c578420c0f6844ee78c588ba841c606ebcb13ea (patch)
tree749206a193a4acf5a19d318a342e2ead2966423c /www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild
parentdev-java/edtftpj: Version bump to 2.4.0, fixes bug #581244 (diff)
downloadgentoo-1c578420c0f6844ee78c588ba841c606ebcb13ea.tar.gz
gentoo-1c578420c0f6844ee78c588ba841c606ebcb13ea.tar.bz2
gentoo-1c578420c0f6844ee78c588ba841c606ebcb13ea.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: portage-2.2.28_p79
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild
deleted file mode 100644
index b246cc856ff6..000000000000
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-51.0.2704.19_alpha.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib unpacker
-
-DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
-HOMEPAGE="https://www.google.com/chrome"
-
-case ${PV} in
- *_alpha*)
- SLOT="unstable"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_alpha}-1
- ;;
- *_beta*)
- SLOT="beta"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_beta}-1
- ;;
- *)
- SLOT="stable"
- CHROMEDIR="opt/google/chrome"
- MY_PV=${PV}-1
- ;;
-esac
-
-MY_PN="google-chrome-${SLOT}"
-MY_P="${MY_PN}_${MY_PV}"
-
-SRC_URI="
- amd64? (
- https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
- )
-"
-KEYWORDS="-* ~amd64"
-
-LICENSE="google-chrome"
-IUSE="+flash +widevine"
-RESTRICT="bindist mirror strip"
-
-for x in 0 beta stable unstable; do
- if [[ ${SLOT} != ${x} ]]; then
- RDEPEND+=" !${CATEGORY}/${PN}:${x}"
- fi
-done
-
-S="${WORKDIR}/${CHROMEDIR}"
-QA_PREBUILT="*"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
-}
-
-src_install() {
- local version flapper
-
- insinto /usr/$(get_libdir)/chromium-browser/
-
- if use widevine; then
- doins libwidevinecdm.so
- strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
- doins widevine.version
- fi
-
- if use flash; then
- doins -r PepperFlash
-
- # Since this is a live ebuild, we're forced to, unfortuantely,
- # dynamically construct the command line args for Chromium.
- version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' PepperFlash/manifest.json)
- flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
- echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
- echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
- echo "--ppapi-flash-version=$version\"" >> pepper-flash
-
- insinto /etc/chromium/
- doins pepper-flash
- fi
-}