summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-09 20:20:39 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-09 20:21:33 -0400
commit7f075311e9664e5f0d6271626c395f60a65924e2 (patch)
treee56abe7ae26882494b046ad2ba18f69b44d86b49 /www-plugins/freshplayerplugin
parentnet-misc/gns3-gui: Add test comments, fix absolute paths, and remove unneeded... (diff)
downloadgentoo-7f075311e9664e5f0d6271626c395f60a65924e2.tar.gz
gentoo-7f075311e9664e5f0d6271626c395f60a65924e2.tar.bz2
gentoo-7f075311e9664e5f0d6271626c395f60a65924e2.zip
www-plugins/freshplayerplugin: Version bump to 0.3.7
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'www-plugins/freshplayerplugin')
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.7.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
index 58cfd8dacfd1..f080808fc70e 100644
--- a/www-plugins/freshplayerplugin/Manifest
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -1 +1,2 @@
DIST freshplayerplugin-0.3.5.tar.gz 781003 SHA256 b08f7c6690de13b1e358fef4cab41cb303b9e80b3504678e94c9646f44dd7104 SHA512 dd447db4cbfdb80b89ff42894099971c100023d19fe5fbad023d5ac1afa827fdc5a169a03f4702ffda3cf6e0dd9c63217b68d97d047ac43afc22f488020a0ba0 WHIRLPOOL cf22758e0ed947db27e8e6e053f17bafc425beebebd9314008eef105e828a0a51f73fd42f2d0c00e12e56f817e2b9078baeb55bd54a6c6a55e8ebd00d2e27ccc
+DIST freshplayerplugin-0.3.7.tar.gz 789974 SHA256 e4c67ff382aacbdf6ecc45095fa48c582e89ce70f94fe6499e00f7d664d5e05f SHA512 9ef534b873833d69caa86a5702ad6150e4aa2fe399159a550b6cb0ebad2754d25e185c54b6285f6f50913c5595c5b460ce3e0d21ac45f0d25793805463ce1d5d WHIRLPOOL f6e6c64c055d85eaf79da62ad24be04def3fa3f5167910e7854b9a633c8b9618dd0629bc8553d2fbc73b7e4f7006b18e0de150be6eb1807b90079e84826956cc
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.7.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.7.ebuild
new file mode 100644
index 000000000000..7f1968d12571
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gles2 gtk3 jack libav libressl pulseaudio v4l vaapi vdpau"
+
+KEYWORDS="~amd64"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?] )
+ x11-libs/libva
+ x11-libs/libvdpau
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2=
+ dev-libs/icu:0=
+ dev-libs/libevent:=[threads]
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/mesa:=[egl,gles2?]
+ x11-libs/cairo:=[X]
+ x11-libs/libXcursor:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/libdrm:=
+ x11-libs/pango:=[X]
+ jack? (
+ media-sound/jack-audio-connection-kit
+ media-libs/soxr
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ !gtk3? ( x11-libs/gtk+:2= )
+ gtk3? ( x11-libs/gtk+:3= )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ v4l? ( media-libs/libv4l:0= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${COMMON_DEPEND}
+ www-plugins/adobe-flash:22[abi_x86_64,ppapi(+)]
+ "
+
+PATCHES=( "${FILESDIR}/0.3.5-cmake.patch" )
+DOCS=( ChangeLog data/freshwrapper.conf.example README.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_JACK=$(usex jack)
+ -DWITH_PULSEAUDIO=$(usex pulseaudio)
+ -DWITH_GTK=$(usex gtk3 3 2)
+ -DWITH_GLES2=$(usex gles2)
+ -DWITH_LIBV4L2=$(usex v4l)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}