summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2018-05-14 06:04:05 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-07 08:22:35 +0200
commitc7387053711bab6ed3740ece001aeb135c89682e (patch)
treea0ebccb5520daf5f2578a2333192177730a26fd3 /www-plugins
parentwww-plugins/passff-host: New Package (diff)
downloadgentoo-c7387053711bab6ed3740ece001aeb135c89682e.tar.gz
gentoo-c7387053711bab6ed3740ece001aeb135c89682e.tar.bz2
gentoo-c7387053711bab6ed3740ece001aeb135c89682e.zip
www-plugins/passff: Bump to 1.3
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/passff/Manifest1
-rw-r--r--www-plugins/passff/metadata.xml7
-rw-r--r--www-plugins/passff/passff-1.3.ebuild37
3 files changed, 45 insertions, 0 deletions
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
index 40c9f56bb393..ff7e637a1e14 100644
--- a/www-plugins/passff/Manifest
+++ b/www-plugins/passff/Manifest
@@ -1,2 +1,3 @@
DIST passff-1.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-1.1.py 2256 BLAKE2B fcde1a8d1fe4e8793df46c182a8d717931e7b5ee98ae39a6a03bf32c51528dd7036beefc47dd5839bede47a78bcb7904a745fa38522183057dd7b29e20eae726 SHA512 b5d4aa3d3a9455adece3d291a6e1e05178296e72828ec708cd33541f30e4fbef2385978f24ba27eaefc739e4792f4cbac1830e8dcd15380c7243e11ddbcafe9d
+DIST passff-1.3-an+fx-linux.xpi 59512 BLAKE2B 48eb41e8be2e090aa32137fe93eb6cb7a22218f865f1ade4e6f4516ea3fedc34333f43438fd7c96817ec695ca1d0ced9cff0dd53157e06442e000c12a4bff33c SHA512 d5e5c29fda852c08908ce27e55bb2cd3daaacedf4f1375eb626cf4228d9b8c5113d2210578d80420c1df3846cbb948c184702274ece851c9e8279000e38989a6
diff --git a/www-plugins/passff/metadata.xml b/www-plugins/passff/metadata.xml
index 764e78624bc3..234e183d237e 100644
--- a/www-plugins/passff/metadata.xml
+++ b/www-plugins/passff/metadata.xml
@@ -8,4 +8,11 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+<use>
+ <flag name="firefox">Install plugin for <pkg>www-client/firefox</pkg></flag>
+ <flag name="firefox-bin">Install plugin for <pkg>www-client/firefox-bin</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="github">passff/passff</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/www-plugins/passff/passff-1.3.ebuild b/www-plugins/passff/passff-1.3.ebuild
new file mode 100644
index 000000000000..2cc136021db6
--- /dev/null
+++ b/www-plugins/passff/passff-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mozextension
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/914592/passff-1.3-an+fx-linux.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firefox firefox-bin"
+
+RDEPEND="www-plugins/passff-host[firefox]"
+REQUIRED_USE="|| ( firefox firefox-bin )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ xpi_unpack "passff-1.3-an+fx-linux.xpi"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ if use firefox; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "passff-1.3-an+fx-linux"
+ fi
+
+ if use firefox-bin; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "passff-1.3-an+fx-linux"
+ fi
+}