summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-09 13:56:36 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-09 13:56:36 +0200
commit1dccbff0478370fa30c4c32871235437e48fa3f3 (patch)
tree8407354396a6e64d3f12b29b40d2ceb85a017c20 /www-servers/gunicorn/files
parentwww-servers/gunicorn: Version Bump (diff)
downloadgentoo-1dccbff0478370fa30c4c32871235437e48fa3f3.tar.gz
gentoo-1dccbff0478370fa30c4c32871235437e48fa3f3.tar.bz2
gentoo-1dccbff0478370fa30c4c32871235437e48fa3f3.zip
www-servers/gunicorn: Drop old
Package-Manager: portage-2.2.20 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn/files')
-rw-r--r--www-servers/gunicorn/files/gunicorn-0.14.0-noegg.patch64
-rw-r--r--www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch59
2 files changed, 0 insertions, 123 deletions
diff --git a/www-servers/gunicorn/files/gunicorn-0.14.0-noegg.patch b/www-servers/gunicorn/files/gunicorn-0.14.0-noegg.patch
deleted file mode 100644
index 7be449f5c6c3..000000000000
--- a/www-servers/gunicorn/files/gunicorn-0.14.0-noegg.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff --git a/tests/003-test-config.py b/tests/003-test-config.py
-index 4d9ef92..218a8e4 100644
---- a/tests/003-test-config.py
-+++ b/tests/003-test-config.py
-@@ -24,12 +24,7 @@ def paster_ini():
- return os.path.join(dirname, "..", "examples", "frameworks", "pylonstest", "nose.ini")
-
- def PasterApp():
-- try:
-- from paste.deploy import loadapp, loadwsgi
-- except ImportError:
-- raise SkipTest()
-- from gunicorn.app.pasterapp import PasterApplication
-- return PasterApplication("no_usage")
-+ raise SkipTest()
-
- class AltArgs(object):
- def __init__(self, args=None):
-@@ -59,43 +54,8 @@ def test_defaults():
- t.eq(s.default, c.settings[s.name].get())
-
- def test_property_access():
-- c = config.Config()
-- for s in config.KNOWN_SETTINGS:
-- getattr(c, s.name)
--
-- # Class was loaded
-- t.eq(c.worker_class, SyncWorker)
--
-- # Debug affects workers
-- t.eq(c.workers, 1)
-- c.set("workers", 3)
-- t.eq(c.workers, 3)
--
-- # Address is parsed
-- t.eq(c.address, ("127.0.0.1", 8000))
--
-- # User and group defaults
-- t.eq(os.geteuid(), c.uid)
-- t.eq(os.getegid(), c.gid)
--
-- # Proc name
-- t.eq("gunicorn", c.proc_name)
--
-- # Not a config property
-- t.raises(AttributeError, getattr, c, "foo")
-- # Force to be not an error
-- class Baz(object):
-- def get(self):
-- return 3.14
-- c.settings["foo"] = Baz()
-- t.eq(c.foo, 3.14)
--
-- # Attempt to set a cfg not via c.set
-- t.raises(AttributeError, setattr, c, "proc_name", "baz")
--
-- # No setting for name
-- t.raises(AttributeError, c.set, "baz", "bar")
--
-+ raise SkipTest()
-+
- def test_bool_validation():
- c = config.Config()
- t.eq(c.debug, False)
diff --git a/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch b/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch
deleted file mode 100644
index 7561ab2f3027..000000000000
--- a/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 86f740420cb12cf071f7dc7981330353e258931a Mon Sep 17 00:00:00 2001
-From: Andrew Svetlov <andrew.svetlov@gmail.com>
-Date: Sun, 22 Jun 2014 15:19:27 +0300
-Subject: [PATCH] Don't install gaiohttp if python < 3.3
-
----
- setup.py | 18 ++++++++++++++++--
- 1 file changed, 16 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index be54106..f538734 100644
---- a/setup.py
-+++ b/setup.py
-@@ -5,12 +5,15 @@
-
-
- import os
--from setuptools import setup, find_packages, Command
-+from setuptools import setup, Command
- import sys
-
- from gunicorn import __version__
-
-
-+ASYNCIO_COMPAT = sys.version_info >= (3, 3)
-+
-+
- CLASSIFIERS = [
- 'Development Status :: 4 - Beta',
- 'Environment :: Other Environment',
-@@ -65,6 +68,17 @@ def run(self):
-
- REQUIREMENTS = []
-
-+py_modules = []
-+
-+for root, folders, files in os.walk('gunicorn'):
-+ for f in files:
-+ if f.endswith('.py') and (ASYNCIO_COMPAT or f != 'gaiohttp.py'):
-+ full = os.path.join(root, f[:-3])
-+ parts = full.split(os.path.sep)
-+ modname = '.'.join(parts)
-+ py_modules.append(modname)
-+
-+
- setup(
- name = 'gunicorn',
- version = __version__,
-@@ -78,7 +92,7 @@ def run(self):
-
- classifiers = CLASSIFIERS,
- zip_safe = False,
-- packages = find_packages(exclude=['examples', 'tests']),
-+ py_modules = py_modules,
- include_package_data = True,
-
- tests_require = tests_require,
---
-1.9.3