summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-19 17:50:16 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-19 18:12:05 -0700
commitdf70bb73f40c4fb0bd37d62b05b813110fe4af54 (patch)
tree1f30783cb4bf95eea51915ddc0ddb980afab95ec /x11-libs/pango
parentdev-libs/glib: Version bump to 2.72.0 (diff)
downloadgentoo-df70bb73f40c4fb0bd37d62b05b813110fe4af54.tar.gz
gentoo-df70bb73f40c4fb0bd37d62b05b813110fe4af54.tar.bz2
gentoo-df70bb73f40c4fb0bd37d62b05b813110fe4af54.zip
x11-libs/pango: Version bump to 1.50.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.50.6.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index ecb07df0b0df..2bdb9d87868f 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -2,3 +2,4 @@ DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
DIST pango-1.50.4.tar.xz 4290504 BLAKE2B 310a7be79ebf693b3a7775fa86557539bf4ea682b0903266248ab2812504e805024b14a917531e71ad9b5637d4d3f3c1a06b84188eb01aeed37fdcc7d11679a9 SHA512 b44cf9bd7afd633fab326e70b69dcb9f00cc26dcc36361793d3654b5ae798a303d4e63e173370f396c4fa474a4118c53076927fe7cc944fc35a32adf3a656806
DIST pango-1.50.5.tar.xz 4291708 BLAKE2B 90a1fc927ee1e06eb76ea6b82e9851e3381d5393a1992db0d3da4d3a934b5bf08f4485b40a9eef58aa906e3f0b74e71f491d947ae00310130ec5e23bde47d836 SHA512 6e898945ca9682ad113cea8a5702068d6141d39bc51a27093c6c1627c10825005155c73778cb5acab99551689dd1b47069f7d5ea102db11f00416ddcf747b8c6
+DIST pango-1.50.6.tar.xz 4293168 BLAKE2B 63cad33f5fe5361642edb0e26a11c45e28e23400f29c078079fa9ce4411eca90c67fdd789e8cf9caec0f1d4a6b5d619808d8dcf53447f961b66db17e1bbcdb97 SHA512 27fe5b2398995fc9103dbb957bb10e5f35284762260fe29366eafd2ba570d90bb0d2f865bd78ed6728417dfde54931f014aaa2155e3eae054e1a45a2a07bf90f
diff --git a/x11-libs/pango/pango-1.50.6.ebuild b/x11-libs/pango/pango-1.50.6.ebuild
new file mode 100644
index 000000000000..13c9fd367584
--- /dev/null
+++ b/x11-libs/pango/pango-1.50.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug +introspection sysprof X"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}