summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 10:24:07 +0100
committerSam James <sam@gentoo.org>2021-04-21 19:50:13 +0100
commit7bd49fb87d26921fc3af44af675716c93269e73c (patch)
tree6de60396f520330fa440daddcdb42fc52f0acb2f /x11-libs/xosd
parentgnome-extra/libgda: drop epatch (diff)
downloadgentoo-7bd49fb87d26921fc3af44af675716c93269e73c.tar.gz
gentoo-7bd49fb87d26921fc3af44af675716c93269e73c.tar.bz2
gentoo-7bd49fb87d26921fc3af44af675716c93269e73c.zip
x11-libs/xosd: port to EAPI 7, drop epatch and versionator
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/xosd')
-rw-r--r--x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch4
-rw-r--r--x11-libs/xosd/xosd-2.2.14_p2_p1.ebuild32
2 files changed, 22 insertions, 14 deletions
diff --git a/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch b/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch
index 8446297f15ce..6aabea7b0d29 100644
--- a/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch
+++ b/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch
@@ -3,8 +3,8 @@ https://bugs.gentoo.org/show_bug.cgi?id=286632
This patch disables reordering and duplicate removing for non-libs arguments, thus --param and alike gcc options may be used safe now.
written by Andrew Savchenko
---- script/xosd-config.in.orig
-+++ script/xosd-config.in
+--- a/script/xosd-config.in
++++ b/script/xosd-config.in
@@ -161,7 +161,6 @@
fi;;
*)
diff --git a/x11-libs/xosd/xosd-2.2.14_p2_p1.ebuild b/x11-libs/xosd/xosd-2.2.14_p2_p1.ebuild
index feb07d82c128..ff2f52b48e31 100644
--- a/x11-libs/xosd/xosd-2.2.14_p2_p1.ebuild
+++ b/x11-libs/xosd/xosd-2.2.14_p2_p1.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit epatch autotools versionator
+EAPI=7
-MY_PV=$(get_version_component_range 1-3)
-MY_PATCH_MAJ=$(get_version_component_range 4)
-MY_PATCH_MIN=$(get_version_component_range 5)
+inherit autotools
+
+MY_PV=$(ver_cut 1-3)
+MY_PATCH_MAJ=$(ver_cut 5)
+MY_PATCH_MIN=$(ver_cut 7)
DESCRIPTION="Library for overlaying text in X-Windows X-On-Screen-Display"
HOMEPAGE="https://sourceforge.net/projects/libxosd/"
SRC_URI="mirror://debian/pool/main/x/xosd/${PN}_${MY_PV}.orig.tar.gz
mirror://debian/pool/main/x/xosd/${PN}_${MY_PV}-${MY_PATCH_MAJ/p/}.${MY_PATCH_MIN/p/}.debian.tar.xz
http://digilander.libero.it/dgp85/gentoo/${PN}-gentoo-m4-1.tar.bz2"
+S="${WORKDIR}"/${PN}-${MY_PV}
LICENSE="GPL-2"
SLOT="0"
@@ -24,22 +26,28 @@ RDEPEND="x11-libs/libX11
x11-libs/libXt
media-fonts/font-misc-misc"
DEPEND="${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
DOCS=(
AUTHORS ChangeLog NEWS README TODO
)
-S=${WORKDIR}/${PN}-${MY_PV}
-src_prepare() {
- epatch "${WORKDIR}"/debian/patches/*.diff
+PATCHES=(
+ "${WORKDIR}"/debian/patches/20_underquoted_definition.diff
+ "${WORKDIR}"/debian/patches/25_fix_mangapges.diff
+ "${WORKDIR}"/debian/patches/30_aclocal.diff
+ "${WORKDIR}"/debian/patches/328676.diff
+ "${WORKDIR}"/debian/patches/35_beep_media_player.diff
+ "${WORKDIR}"/debian/patches/54_fix_man_makefile.diff
# bug #286632
- epatch "${FILESDIR}"/"${PN}"-config-incorrect-dup-filter-fix.patch
+ "${FILESDIR}"/${PN}-config-incorrect-dup-filter-fix.patch
+)
- eapply_user
+src_prepare() {
+ default
- AT_M4DIR="${WORKDIR}/m4" eautoreconf
+ AT_M4DIR="${WORKDIR}"/m4 eautoreconf
}
src_configure() {