summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-16 11:25:08 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-30 20:06:59 +0200
commit2db8035c8048ab301abac09c31661bf328c0cfee (patch)
tree7c6825a7a71b6a62f273b14ac6ab34cbe8b2d6f2 /x11-libs
parentapp-emulation/dxvk: Stabilize 2.4 amd64, #936951 (diff)
downloadgentoo-2db8035c8048ab301abac09c31661bf328c0cfee.tar.gz
gentoo-2db8035c8048ab301abac09c31661bf328c0cfee.tar.bz2
gentoo-2db8035c8048ab301abac09c31661bf328c0cfee.zip
x11-libs/gdk-pixbuf: Bump to 2.42.12
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36701 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/Manifest1
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.42.12.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf/Manifest b/x11-libs/gdk-pixbuf/Manifest
index 9f22e8781787..ed3f5b7b135a 100644
--- a/x11-libs/gdk-pixbuf/Manifest
+++ b/x11-libs/gdk-pixbuf/Manifest
@@ -1 +1,2 @@
DIST gdk-pixbuf-2.42.10.tar.xz 6519776 BLAKE2B b6bec388b70a971ea5b336001920fdf433bcbc539d54e62c7b6198e968f0bd3560ef9adc94215b64b01e7d5db69c95d5a1d32654b38b051fceb75e93666b3385 SHA512 ad64963b61ef8cc84ae450328ec8c90a852f974e29ffdd42263ed32de47af93c058f3ffdf91c5d6e9bba815f4e8e8fe5a19422ac1bfb079666339814ac059b3a
+DIST gdk-pixbuf-2.42.12.tar.xz 6525072 BLAKE2B 718a96c9efb836a275692ccbc403df0eb285918c5867d344406f660898c7ce8aad8cce7187faf7f6e9cdcfd1b051d5384f57644d946b888baddbaafb8f99309c SHA512 ae9fcc9b4e8fd10a4c9bf34c3a755205dae7bbfe13fbc93ec4e63323dad10cc862df6a9e2e2e63c84ffa01c5e120a3be06ac9fad2a7c5e58d3dc6ba14d1766e8
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.42.12.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.42.12.ebuild
new file mode 100644
index 000000000000..3a669285f2af
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.42.12.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson-multilib multilib xdg
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gdk-pixbuf"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="gtk-doc +introspection gif jpeg test tiff"
+RESTRICT="!test? ( test )"
+
+# TODO: For windows/darwin support: shared-mime-info conditional, native_windows_loaders option review
+DEPEND="
+ >=dev-libs/glib-2.56.0:2[${MULTILIB_USEDEP}]
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}]
+ jpeg? ( media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.2:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/glib:2
+ dev-libs/libxslt
+ dev-python/docutils
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gdk-pixbuf-query-loaders$(get_exeext)
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dpng=enabled
+ $(meson_feature gif)
+ -Dothers=enabled
+ $(meson_feature tiff)
+ $(meson_feature jpeg)
+ -Dbuiltin_loaders=png,jpeg
+ -Drelocatable=false
+ #native_windows_loaders
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ -Dgio_sniffing=true
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_native_use_feature introspection)
+ $(meson_native_true man)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/gdk-pixbuf "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/gdk-pixdata "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
+
+ if [[ -e ${EROOT}/${cache} ]]; then
+ cp "${EROOT}"/${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+
+ multilib_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ multilib_foreach_abi gnome2_gdk_pixbuf_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ rm -f "${EROOT}"/usr/lib*/${PN}-2.0/2.10.0/loaders.cache
+ fi
+}