summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-26 03:10:54 +0100
committerSam James <sam@gentoo.org>2023-04-26 03:10:54 +0100
commitf688df5100ef2b88c975ecd40fd343c62e2ab276 (patch)
tree00ab496b7a2f23172eb48871b7a3f85da2ec90f7 /x11-libs
parentwww-client/chromium: fix build with GCC 13 (diff)
downloadgentoo-f688df5100ef2b88c975ecd40fd343c62e2ab276.tar.gz
gentoo-f688df5100ef2b88c975ecd40fd343c62e2ab276.tar.bz2
gentoo-f688df5100ef2b88c975ecd40fd343c62e2ab276.zip
x11-libs/pango: workaround -Werror=array-bounds issue w/ GCC 13
Seems to be a false positive. Reported upstream by Adrien at https://gitlab.gnome.org/GNOME/pango/-/issues/740. Happens w/ GCC 13 combined with -O3 at least but may happen for other combinations too. Can't append -Wno-error=... because of the order the flags are added, unfortunately. Closes: https://bugs.gentoo.org/903259 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/pango-1.50.14.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-libs/pango/pango-1.50.14.ebuild b/x11-libs/pango/pango-1.50.14.ebuild
index 6160dd53090e..690dbbb2d084 100644
--- a/x11-libs/pango/pango-1.50.14.ebuild
+++ b/x11-libs/pango/pango-1.50.14.ebuild
@@ -45,6 +45,10 @@ src_prepare() {
default
xdg_environment_reset
gnome2_environment_reset
+
+ # False positive with GCC 13 and -O3 at least, see bug #903259
+ # https://gitlab.gnome.org/GNOME/pango/-/issues/740
+ sed -i -e '/\-Werror=array-bounds/d' meson.build || die
}
multilib_src_configure() {