summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-03-09 14:19:05 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-09 14:56:28 +0100
commit92e69d2ca0c365e3b37ad193c0e15ad58bb605c6 (patch)
tree6aecc18094e9058e4903440387221f4f3e0bf7f5 /x11-misc/dunst
parentdev-util/intel-graphics-compiler: add 1.0.15985.15 (diff)
downloadgentoo-92e69d2ca0c365e3b37ad193c0e15ad58bb605c6.tar.gz
gentoo-92e69d2ca0c365e3b37ad193c0e15ad58bb605c6.tar.bz2
gentoo-92e69d2ca0c365e3b37ad193c0e15ad58bb605c6.zip
x11-misc/dunst: add 1.10.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc/dunst')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.10.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index d89fad77b99a..e0ac3e608bdf 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,2 +1,3 @@
+DIST dunst-1.10.0.tar.gz 4639084 BLAKE2B 29056b55aa53e20d4d9f0be5ff560aaad3829a933f30fd6a6f17f5e6adb9f4ca3b659dc977959f69224a2847a116043215e05097e9eaae4556ec02c1852c4a05 SHA512 e7e453c9470a063cdee4602315b22c1c8bcbf1405d3c295bccf01ae4e1b535e11b7323313b63cfc510e38ea8243117d550e6057df15924bbd4efb7e0b7f9a709
DIST dunst-1.9.1.tar.gz 4614410 BLAKE2B f2d3b5ca28ac74461e31c09f7c5f8369dd6d05e8133d184625344b5445fac8e673cf5c57d44ea8bf0f3d320167663529ea49e8de0ed873afae327cb7db55d5ff SHA512 6045529196c2d8bd89d2976db9712bf15ec75923fdab414870e1ae2af2eb87afc2b5886cb707a19ea113ec746f90fde1e52631eec9b7a96f1af03acbe6445f32
DIST dunst-1.9.2.tar.gz 4614703 BLAKE2B bcdb3f36dd9af546288c35ffc90f08b219b1b4d1d11233b09acfbe9e6287dcfd856200310d88115a6009485af5e9b0d4e2933bff9cade38969cea31b167c9b5b SHA512 fab14212dc41e8deed97320c18b88e0be576f0404406691dcedb9620a1382dfdfc501e4ff2005b1ce8b4a61b52f1a9cf161f20a1eae15aa2382f3fedc99a2dbc
diff --git a/x11-misc/dunst/dunst-1.10.0.ebuild b/x11-misc/dunst/dunst-1.10.0.ebuild
new file mode 100644
index 000000000000..a8f132ef8e64
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.10.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit shell-completion systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ x11-libs/pango[X]
+ x11-misc/xdg-utils
+ wayland? ( dev-libs/wayland )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ newbashcomp contrib/dunst.bashcomp dunst
+ newbashcomp contrib/dunstctl.bashcomp dunstctl
+ newfishcomp contrib/dunst.fishcomp dunst
+ newfishcomp contrib/dunstctl.fishcomp dunstctl
+ newfishcomp contrib/dunstify.fishcomp dunstify
+ newzshcomp contrib/_dunst.zshcomp _dunst
+ newzshcomp contrib/_dunstctl.zshcomp _dunstctl
+
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}