summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 18:34:50 +0000
committerSam James <sam@gentoo.org>2021-04-25 19:13:29 +0000
commitd9a6680070254679a500207f66f7d23a7f567a53 (patch)
tree28aed3b9a7757c2ae944234a1a2a9f20ef6e6308 /x11-misc/flow-pomodoro/files
parentmedia-libs/resid: port to EAPI 7, drop ltpune, drop static-libs, etc (diff)
downloadgentoo-d9a6680070254679a500207f66f7d23a7f567a53.tar.gz
gentoo-d9a6680070254679a500207f66f7d23a7f567a53.tar.bz2
gentoo-d9a6680070254679a500207f66f7d23a7f567a53.zip
x11-misc/flow-pomodoro: respect CXXFLAGS
We also use the more modern macro to detect C++11. Closes: https://bugs.gentoo.org/742776 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/flow-pomodoro/files')
-rw-r--r--x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch
new file mode 100644
index 000000000000..0da271d43b06
--- /dev/null
+++ b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch
@@ -0,0 +1,23 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,15 +12,16 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ include_directories(${Qt5Core_INCLUDES})
+ include_directories(${Qt5Gui_INCLUDES})
+
+-set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
++set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS} ${CMAKE_CXX_FLAGS}")
+
+ include(CheckCXXCompilerFlag)
++
+ CHECK_CXX_COMPILER_FLAG("-std=c++11" COMPILER_SUPPORTS_CXX11)
+ CHECK_CXX_COMPILER_FLAG("-std=c++0x" COMPILER_SUPPORTS_CXX0X)
++set(CMAKE_CXX_STANDARD_REQUIRED on)
++
+ if(COMPILER_SUPPORTS_CXX11)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+-elseif(COMPILER_SUPPORTS_CXX0X)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set(CMAKE_CXX_STANDARD 11)
+ else()
+ message(STATUS "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. Please use a different C++ compiler.")
+ endif()