summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Wolf <etc404@protonmail.com>2022-10-28 12:26:43 -0600
committerFlorian Schmaus <flow@gentoo.org>2022-11-01 10:59:55 +0100
commit936428d70e5d07af9a282fc99fdbd49f8526e724 (patch)
treed5c99ef762ff8b8dad46cb9556286e294065b080 /x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild
parentapp-admin/analog: Keyword 6.0.13 riscv, #878953 (diff)
downloadgentoo-936428d70e5d07af9a282fc99fdbd49f8526e724.tar.gz
gentoo-936428d70e5d07af9a282fc99fdbd49f8526e724.tar.bz2
gentoo-936428d70e5d07af9a282fc99fdbd49f8526e724.zip
x11-misc/nitrogen: Add myself as maintainer, add metainfo patch, and resolve #784320
Closes: https://bugs.gentoo.org/784320 Signed-off-by: Dylan Wolf <etc404@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/27629 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild')
-rw-r--r--x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild b/x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..4c91440c9442
--- /dev/null
+++ b/x11-misc/nitrogen/nitrogen-1.6.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic xdg-utils
+
+DESCRIPTION="A background browser and setter for X"
+HOMEPAGE="https://github.com/l3ib/nitrogen"
+SRC_URI="https://github.com/l3ib/nitrogen/releases/download/${PV}/${P}.tar.gz"
+KEYWORDS="amd64 ~ppc x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls xinerama"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-cpp/gtkmm-2.10:2.4
+ >=gnome-base/librsvg-2.20:2
+ >=x11-libs/gtk+-2.10:2
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-base/xorg-proto )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-appdata-install-location.patch" # https://github.com/l3ib/nitrogen/pull/156
+)
+
+src_prepare() {
+ default
+ mv data/nitrogen.{appdata,metainfo}.xml || die
+
+ sed -i -e '/^UPDATE_DESKTOP/s#=.*#= :#g' data/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}