summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-30 11:03:46 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-30 11:30:26 +0100
commitf79a3ff9bf5e7b2297fb5e06eb9fd784e3415f7b (patch)
tree82aceef622f36322e959939e92148d37bd6d570a /x11-misc/wayv/wayv-0.3-r3.ebuild
parentdev-python/lxml: arm stable wrt bug #707070 (diff)
downloadgentoo-f79a3ff9bf5e7b2297fb5e06eb9fd784e3415f7b.tar.gz
gentoo-f79a3ff9bf5e7b2297fb5e06eb9fd784e3415f7b.tar.bz2
gentoo-f79a3ff9bf5e7b2297fb5e06eb9fd784e3415f7b.zip
x11-misc/wayv: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707196 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/wayv/wayv-0.3-r3.ebuild')
-rw-r--r--x11-misc/wayv/wayv-0.3-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/wayv/wayv-0.3-r3.ebuild b/x11-misc/wayv/wayv-0.3-r3.ebuild
new file mode 100644
index 000000000000..cfda0bef6e80
--- /dev/null
+++ b/x11-misc/wayv/wayv-0.3-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Wayv is hand-writing/gesturing recognition software for X"
+HOMEPAGE="http://www.stressbunny.com/wayv"
+SRC_URI="http://www.stressbunny.com/gimme/wayv/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-autoconf.patch
+ "${FILESDIR}"/${PN}-0.3-flags.patch
+ "${FILESDIR}"/${PN}-0.3-fno-common.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ cd doc
+ default
+ dodoc HOWTO*
+}