summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-24 08:44:14 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-25 15:15:05 +0100
commit49ed82a2ff850060ca3c20a5b0416827cc88d00b (patch)
tree3c093bfceab8f3e0b594b89b6986d7f3612e49e2 /x11-misc/xwit/xwit-3.4_p15.ebuild
parentx11-misc/unclutter: EAPI bump 5 -> 6 (diff)
downloadgentoo-49ed82a2ff850060ca3c20a5b0416827cc88d00b.tar.gz
gentoo-49ed82a2ff850060ca3c20a5b0416827cc88d00b.tar.bz2
gentoo-49ed82a2ff850060ca3c20a5b0416827cc88d00b.zip
x11-misc/xwit: Use debian patches
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4071
Diffstat (limited to 'x11-misc/xwit/xwit-3.4_p15.ebuild')
-rw-r--r--x11-misc/xwit/xwit-3.4_p15.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xwit/xwit-3.4_p15.ebuild b/x11-misc/xwit/xwit-3.4_p15.ebuild
new file mode 100644
index 000000000000..f7b93a5dc726
--- /dev/null
+++ b/x11-misc/xwit/xwit-3.4_p15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
+HOMEPAGE="https://tracker.debian.org/pkg/xwit"
+SRC_URI="
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}.orig.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p/-}.debian.tar.gz
+"
+
+LICENSE="public-domain HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${P/_p*/}.orig
+
+PATCHES=( "${WORKDIR}"/debian/patches )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|gcc|${CC}|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin xwit
+ newman xwit.man xwit.1
+ einstalldocs
+}