summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-25 07:38:16 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-25 07:40:15 -0500
commit198dccc8c2791fac9b7c287d1b350b42ba707695 (patch)
tree278db1793101b8a0a6a16a8db81bfe205881517d /x11-misc
parentdev-ruby/mimemagic: mark extension as installed (diff)
downloadgentoo-198dccc8c2791fac9b7c287d1b350b42ba707695.tar.gz
gentoo-198dccc8c2791fac9b7c287d1b350b42ba707695.tar.bz2
gentoo-198dccc8c2791fac9b7c287d1b350b42ba707695.zip
x11-misc/slop: backport missing header fix
Closes: https://bugs.gentoo.org/810349 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slop/files/slop-7.5-missing-header.patch16
-rw-r--r--x11-misc/slop/slop-7.5.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/x11-misc/slop/files/slop-7.5-missing-header.patch b/x11-misc/slop/files/slop-7.5-missing-header.patch
new file mode 100644
index 000000000000..f77fe8f9cf88
--- /dev/null
+++ b/x11-misc/slop/files/slop-7.5-missing-header.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/810349
+
+https://github.com/naelstrof/slop/commit/5cbcb9e
+From: Drunkard Zhang <gongfan193@gmail.com>
+Date: Tue, 28 Sep 2021 12:20:25 +0800
+Subject: [PATCH] bugfix: add missed header
+
+XDestroyImage is included in <X11/Xutil.h> which belongs to libX11.
+Build fails without include this header on Gentoo.
+--- a/src/framebuffer.cpp
++++ b/src/framebuffer.cpp
+@@ -1,3 +1,4 @@
++#include <X11/Xutil.h>
+ #include "framebuffer.hpp"
+
+ slop::Framebuffer::Framebuffer( int w, int h ) {
diff --git a/x11-misc/slop/slop-7.5.ebuild b/x11-misc/slop/slop-7.5.ebuild
index e3d08d39be3c..2a2d4fd07ad8 100644
--- a/x11-misc/slop/slop-7.5.ebuild
+++ b/x11-misc/slop/slop-7.5.ebuild
@@ -35,6 +35,10 @@ DEPEND="${RDEPEND}
media-libs/glm
"
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-header.patch
+)
+
src_configure() {
local mycmakeargs=(
-DSLOP_OPENGL=$(usex opengl)